FAQ  •  Register  •  Login

[WoW] Disable Keymaps entering a region, and enable when leaving

Moderator: MiRai

<<

Xiss

Posts: 7

Joined: Sat Sep 01, 2018 9:51 am

Post Sat Apr 06, 2019 11:28 am

Disable Keymaps entering a region, and enable when leaving

Hi sorry if this was answered before, I looked around and couldn't figure how to do it.
I will try to explain the best I can what I'm trying to achieve.

I made a team composed by a paladin, 3 shamans and a hunter. I want to setup a repeater region so that all of my shamans heal the target that i'm clicking, and I can do this.
but if I'm spamming my dps keys the shamans only will start healing once their previous cast is done, I want them to start heal as soon I press my mouse key (I'm using clique to heal)
The way I kinda fix it to stop casting was to to do a wow macro and call it every time I enter/leave the repeater region, but this sometimes feels bit sloppy, because it also does /stopcasting when leaving the region and they will regain assist from spamming dps key and start doing dps rotation again.
It's possible to just stop all keyboard broadcasting to the other windows while I'm inside the repeater region, and start once I'm not with my mouse there ? this would prevent my shamans to regain the assist target from my paladin while im still dpsing.
<<

MiRai

User avatar

Vibrant Videographer

Posts: 2899

Joined: Fri Nov 20, 2009 3:30 pm

Post Sat Apr 06, 2019 1:36 pm

Re: Disable Keymaps entering a region, and enable when leaving

A two-step Mapped Key that first disables, and then re-enables any desired Key Map(s) or Mapped Key(s) for those particular Characters/Slots should do the trick.
<<

Xiss

Posts: 7

Joined: Sat Sep 01, 2018 9:51 am

Post Sun Apr 07, 2019 4:28 pm

Re: Disable Keymaps entering a region, and enable when leaving

Hi MiRai thank you for your response, but I cant seem to be able to make this to work.
I created a Mapped Key called Region Repeater that is called on when I enter/leave the repeater region, but it does not stop key broadcasting.

Paladin and Hunter have the keymap called ISB42 - Ranged Hotkeys and the shamans the ISB42 - Shamans Hotkeys, I attached a image that might show what is wrong, but I cant seem to understand why.
Attachments
isboxer.png
isboxer.png (78.13 KiB) Viewed 2701 times
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3661

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sun Apr 07, 2019 4:33 pm

Re: Disable Keymaps entering a region, and enable when leaving

The image doesn't really show a lot other than you have some key maps.

You should share your profile. http://www.isboxer.com/wiki/Configuration_Sharing
<<

Xiss

Posts: 7

Joined: Sat Sep 01, 2018 9:51 am

Post Sun Apr 07, 2019 5:10 pm

Re: Disable Keymaps entering a region, and enable when leaving

Hi bob I checked the tuturial I will upload my profile, hope you can see whats wrong.
edit: I think I know what is wrong here, the key maps for ranged have the keys being sent to all characters, and not to a action group, Ive been lazy in updating my profile.
Attachments
profile.xml
(719.01 KiB) Downloaded 59 times
<<

MiRai

User avatar

Vibrant Videographer

Posts: 2899

Joined: Fri Nov 20, 2009 3:30 pm

Post Sun Apr 07, 2019 5:29 pm

Re: Disable Keymaps entering a region, and enable when leaving

I don't see how the Mapped Key is being executed, so, as far as I can tell, those Actions aren't being fired off. With that said, using a Click Bar, instead of a Repeater Region, would allow you to assign a two-step Mapped Key to the "Mouseover" section of it, and it would execute Step one upon entering the Click Bar region, and then execute Step two upon exiting.
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3661

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sun Apr 07, 2019 5:41 pm

Re: Disable Keymaps entering a region, and enable when leaving

ok,
So, yes, you disable the Shamans Hotkeys on running of the mapped key step 1 and re-enabled on step 2 (I assume it runs and you see the popups?? if not that may be what part of your issue is).

I suspect the main part of your issue is your other mapped keys. Like the Paladin mapped keys (in Key Map ISB42 - Ranged Hotkeys) are sending instructions to multiple slots, and some of those slots happen to be Shamans.
e.g.
Image
In this case, even though the Shaman Key Map is disabled, the Ranged Key Map (assigned to the Paladin), while still active would be sending to slots 1 to 4 (of which 2, 3, and 4 are Shamans).

I don't specifically know which are your DPS keys, but they all show much the same issue as above, either sending to specific slots or All windows.
<<

Xiss

Posts: 7

Joined: Sat Sep 01, 2018 9:51 am

Post Sun Apr 07, 2019 6:04 pm

Re: Disable Keymaps entering a region, and enable when leaving

Yes bob I see the popups on the screen when i mouseover the region and leave, so yes the problem is the way I have my keys setup, the keys are been sent to all windows from the paladin key map.
A quick way to fix for now is just disable the key map of the paladin and that will stop the keys from being broadcast to the rest of the characters, not quite what i wanted but will do till I decided to start a new profile from scratch again.

@MiRai my profile is flawed, it works quite well if I play 5 characters of the same classe/spec but if I try to do a mixed team its not not that great.
The repeater Region is working, is just the way I have my keys maps/action groups that are wrong.

Thanks for the Help guys.
love your vids MiRai

Return to Repeater

Who is online

Users browsing this forum: No registered users and 1 guest