FAQ  •  Register  •  Login

Trove now crashes after loading screen

Moderator: MiRai

<<

Smedbox

Posts: 86

Joined: Mon May 30, 2011 12:41 am

Post Fri Oct 28, 2016 2:11 pm

Trove now crashes after loading screen

I've had no problems until now after InnerSpace got updated (v1.15 build 6143), but now Trove will always crash right after the loading screen has been displayed. Trove works fine when not launching via InnerSpace. This happens on all of computers (4). (As a comparison, RIFT starts up fine.)
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3749

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Fri Oct 28, 2016 3:04 pm

Re: Trove now crashes after loading screen

You are on the Dev Build no doubt. The current release is 6136.

viewtopic.php?f=18&t=8218
<<

Smedbox

Posts: 86

Joined: Mon May 30, 2011 12:41 am

Post Fri Oct 28, 2016 3:10 pm

Re: Trove now crashes after loading screen

Yes, I know I'm on a dev build.

Though I tried with the official build now too (v1.15 build 6136), and it crashes the same way.
<<

Smedbox

Posts: 86

Joined: Mon May 30, 2011 12:41 am

Post Fri Oct 28, 2016 5:47 pm

Re: Trove now crashes after loading screen

This crash issue is possibly triggered by the recent Trove update the other day.

Is anyone able to launch Trove via InnerSpace at all today (any IS build version)?
<<

lax

User avatar

Site Admin

Posts: 7146

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Oct 29, 2016 2:01 am

Re: Trove now crashes after loading screen

Please provide compatibility diagnostics from ISBoxer's Help menu. http://isboxer.com/wiki/Diagnostics Do you get a crash window? Any further information you can provide?

This goes pretty much any time you're getting new crashes, regardless of how many PCs you have, so we can better understand what is going on.




I'm on the road at the moment, so you'll have to excuse my relative inability to download Trove for testing for the next couple of days. I have it installed at home but Glyph is not cooperating with me over RDP (and I'm just trying to get it to patch stuff so I'm not even using Inner Space yet).

As nobody else has chimed in, I'm currently operating on the assumption that others are not having the issue. (Generally speaking, your question is backwards -- people will check the forums if they are having issues, but people who are not having issues are busy playing)
<<

lax

User avatar

Site Admin

Posts: 7146

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Oct 29, 2016 8:14 am

Re: Trove now crashes after loading screen

MiRai tried running it this morning and mentions that it works fine for him under Inner Space, but not as part of a Character Set. Usually this would indicate something Window Layout related -- can you try detaching your Window Layout from your Character Set and see if the problem still occurs?
<<

Smedbox

Posts: 86

Joined: Mon May 30, 2011 12:41 am

Post Sat Oct 29, 2016 1:25 pm

Re: Trove now crashes after loading screen

Here's the diagnostics: http://pastebin.com/8EGMDvin

I get the Trove crash error handler dialog box that says "Trove has encountered an error" with send/skip buttons.
All machines I tried on are running Windows 10 with the latest system updates (there was one update very recently, and that could also be the trigger).

When you say running under IS but not as part of a Character Set, do you mean right-clicking on IS and choosing "Trove" -> "Trove Default Profile"? This crashes in the same way for me.

I'm currently trying to run it with device=opengl in the Trove.cfg to see if that makes any difference, but it seems I haven't found the virtualized .cfg file yet...

(Btw, another reason other people haven't reported it (yet) could be that no one else have actually tried multiboxing Trove with IS in the past few days... ;))
<<

Smedbox

Posts: 86

Joined: Mon May 30, 2011 12:41 am

Post Sat Oct 29, 2016 1:41 pm

Re: Trove now crashes after loading screen

Well, success! Running it with OpenGL works, both when running with the full character set as well as running just one instance using Trove Default Profile. (Well, "success" in that it doesn't crash, but running with OpenGL sucks, and my videofx picture-in-picture doesn't seem to work in OpenGL mode...)

I modified the virtualized C:\Users\${USERNAME}\AppData\Roaming\Trove\Trove.cfg file by changing the "Device = directx" to 'Device = opengl" in the Rendering section.

So running Trove with DirectX under IS crashes. Perhaps there's some issue with the d3d hooking. Perhaps either the Win10 system update changed something, or the Trove client is now using D3D differently...
<<

Smedbox

Posts: 86

Joined: Mon May 30, 2011 12:41 am

Post Wed Nov 02, 2016 3:07 pm

Re: Trove now crashes after loading screen

Any chance of having a look at this Trove crash soon?

Having to run Trove in OpenGL mode is pretty awful (extremely low framerate, IS features not working, etc)... :/
<<

lax

User avatar

Site Admin

Posts: 7146

Joined: Tue Nov 17, 2009 9:32 pm

Post Wed Nov 02, 2016 5:56 pm

Re: Trove now crashes after loading screen

Yes, I am catching up on issues with various games now that I'm off the road again. Updates soon :)
Next

Return to Trove

Who is online

Users browsing this forum: No registered users and 1 guest