Page 1 of 1

Diablo 3 failing to launch.

PostPosted: Fri Mar 30, 2018 9:10 am
by Zilix

Recently started playing again and can't seem to get either my old profiles that used to work or new one's I've created trying to debug the issue to launch the game at all.

The Inner Space console says "Successfully executed '"E:\Program Files (x86)\Diablo III\Diablo III.exe" -launch'. But the game never actually launches. I see it appear in the task manager for a second or two but then closes. There is nothing spit out the Diablo debug files.

I've tried launching both 32/64 bit versions, launcher on/off. With no window layouts, single profile, etc.

Not sure what the issue could be at this point. Wish I could just see the error that is causing the game to close. Is there a way to get more info on the launcher process and what it's doing?

Attached diagnostic report. I've tried to disable everything that seems like it would interfere.

Re: Diablo 3 failing to launch.

PostPosted: Fri Mar 30, 2018 9:19 am
by Zilix
Trying previous versions atm. These are the errors I'm getting for them. So far they seem to error out earlier in the process than the latest one does. I haven't messed around with the configs for each of these versions yet, not sure if any settings would need to change.

6255 gives: "Failed to execute E:\Program Files (x86)\Diablo III\Diablo III.exe."
6180 gives: "Failed to attach to E:\Program Files (x86)\Diablo III\Diablo III.exe."
* Note: in this version the profiles that don't skip the launcher at least launch the Bnet launcher. The other versions haven't done this. Still get the same error though when I start the game from the launcher though.
6174 gives: "Failed to attach to E:\Program Files (x86)\Diablo III\Diablo III.exe."

Re: Diablo 3 failing to launch.

PostPosted: Fri Mar 30, 2018 10:01 am
by Zilix
Found more info on the error with version 6260. This is what's showing in the window's event viewer:

Also attached the crash report the event references.

Faulting application name: Diablo III Launcher.exe, version:, time stamp: 0x5914c5b6
Faulting module name: InnerSpace.dll, version:, time stamp: 0x5aa3fe2c
Exception code: 0xc0000005
Fault offset: 0x0002a931
Faulting process id: 0x209c
Faulting application start time: 0x01d3c837b36c588b
Faulting application path: E:\Program Files (x86)\Diablo III\Diablo III Launcher.exe
Faulting module path: C:\Program Files (x86)\InnerSpace\InnerSpace.dll
Report Id: f13e5a71-342a-11e8-befb-ac220bc41a23
Faulting package full name:
Faulting package-relative application ID:

Fault bucket 2109865972941067656, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: Diablo III Launcher.exe
P3: 5914c5b6
P4: InnerSpace.dll
P6: 5aa3fe2c
P7: c0000005
P8: 0002a931

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Diablo III Launc_345ffaaf9d190423cf43c7e7747b57db1ab4c8_1cb7f911

Analysis symbol:
Rechecking for solution: 0
Report Id: f13e5a71-342a-11e8-befb-ac220bc41a23
Report Status: 0
Hashed bucket: 80d2b4ea5500ea43ad47bfec80d61588

Re: Diablo 3 failing to launch.

PostPosted: Fri Mar 30, 2018 2:33 pm
by bob
Four things stand out.
  1. Shutdown NVidia Share.
  2. You could update your graphics driver to the latest version. If you update you only really need the drivers and phsyx. The rest is fluff, and best left off for testing purposes.
  3. Maybe grab the files the crash report refers to. Especially if one of them is a memory dump.
  4. Update to a supported operating system. Windows 8 was so bad even Microsoft do not support it, and yet they still support Windows XP. Yes, this is a bit harsh and drastic, but I'm not sure we even have a test system for Windows 8 anymore.

Re: Diablo 3 failing to launch.

PostPosted: Fri Mar 30, 2018 3:05 pm
by Zilix
Yeah, starting fresh with Windows 10 did the trick. Up and running first try with no issues.

Good luck to those who have similar issues on windows 8 and don't have the option to upgrade like I did. Reinstalling diablo/isBoxer/innerspace and updating graphic drivers seem like reasonable next steps that I might have taken.