Page 1 of 1

McAfee conflicts with Innerspace

PostPosted: Fri Jan 26, 2024 11:23 pm
by irongrinder
LavishBuild: Process already has elevated permissions. Checking if file is in use...
LavishBuild: File C:\Program Files (x86)\InnerSpace\InnerSpace.exe is in use by...
# 1. PID 6724. McAfee Framework Host (C:\Program Files\McAfee\WPS\\mc-fw-host.exe)
LavishBuild: Please shut down these processes before continuing
Try again? [Y/n]

I have McAfee Total Protection. I called tech support at McAfee. They said, "There is no way to allow a process to be stopped". I tried in the Task Manager without success.

What can Innerspace do to work around this problem?

Re: McAfee conflicts with Innerspace

PostPosted: Sat Jan 27, 2024 12:13 am
by bob
If a process (McAfee) locks a file, that process needs to release the file lock. There is nothing another process (InnerSpace) can do to force McAfee to release the file lock that McAfee is holding. The best that InnerSpace could do would be to attempt to kill the McAfee process, much the same as you have tried already via Task Manager. That would appear to be a futile approach.

It is a McAfee product issue. Antivirus/Security suite products do need to take file locks to check/scan the file and to make sure it is not being nefarious, but it also needs to release those locks too, otherwise, as has been noted, you cannot delete said file.

The below is just general observations of potential options.
Another user who had the same issue found their solution was to remove the McAfee product from their computer as it was not behaving like a good citizen.

You may be able to exclude the Inner Space folder from the McAfee product. In previous examples of annoyances like this, I've found you can exclude the folder from the "real time" protection but still include it in the "I do a scan daily/weekly" part of the system. No idea if the McAfee product works like this as the last time I used that particular product, McAfee himself still worked on it.