FAQ  •  Register  •  Login

LOTRO :still getting black screen after launch succeeded

Moderator: MiRai

<<

zoopsie

Posts: 34

Joined: Sun Feb 08, 2015 7:15 pm

Post Sat Nov 24, 2018 12:53 am

Re: LOTRO :still getting black screen after launch succeeded

bob wrote:Other news is that there is a confirmed crash, but this is fairly intermittent (i.e. I can launch a full team with a couple of attempts). This does seem to be different to your issue though. So, I suspect at this point your issue is going to potentially be something with the AMD drivers, so if you can continue on the path of shutting down the desktop overlay, and retrying, it will hopefully at least get you up and running.



So i disabled those two problemes, checked after reinstallation of the drivers that they were not anymore on the computer.

Lauch the game normally first, no problems

Then tried with Inner : the first account went through, but so far after 10 attempts for each of the 2 others accounts, no way to log.


Now i noticed something. Each time i reinstall Inner, my first attempt at log in through it on the game works fine for the 3 accounts. The problem starts once i have quit the game and want to go in again, be immediatly or after hours.
Each time i reinstall Inner i disable norton, to be sur the install goes smoothly

Well for now i have no more idea. arghh lol
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3307

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sat Nov 24, 2018 2:25 am

Re: LOTRO :still getting black screen after launch succeeded

The only reason that kind of behaviour would occur, i.e. works after a reinstall, is that something is actively blocking it. Looking at your previous diagnostic, the most likely choice would be Norton's. You can try setting excludes for the InnerSpace folder, or even InnerSpace.exe and lotroclient.exe from the realtime scanning. See if that helps. A better test would actually be to uninstall it altogether (this removes the filter drivers that do not get disabled if you disable it). You wont be exposing your computer if you do this, as the built in Windows Defender will take over (it is perfectly suitable provided you don't go poking in the darker corners of the internet. You can always put Nortons back on if the problem does not resolve.
<<

zoopsie

Posts: 34

Joined: Sun Feb 08, 2015 7:15 pm

Post Sun Nov 25, 2018 9:04 am

Re: LOTRO :still getting black screen after launch succeeded

bob wrote:The only reason that kind of behaviour would occur, i.e. works after a reinstall, is that something is actively blocking it. Looking at your previous diagnostic, the most likely choice would be Norton's. You can try setting excludes for the InnerSpace folder, or even InnerSpace.exe and lotroclient.exe from the realtime scanning. See if that helps. A better test would actually be to uninstall it altogether (this removes the filter drivers that do not get disabled if you disable it). You wont be exposing your computer if you do this, as the built in Windows Defender will take over (it is perfectly suitable provided you don't go poking in the darker corners of the internet. You can always put Nortons back on if the problem does not resolve.



Did all you suggested, nothing changed at all.

After that i decided to modify just 2 file of yours :

Game detection, i replaced the Turbine folder by the one actually in the installation :

Code:
    <Detection>
      <FileExists Filename="%PROGRAMFILES%\StandingStoneGames\The Lord of the Rings Online\TurbineLauncher.exe" />
    </Detection>
  </Game>


Game configuration, i replaced all mention of DDO pointing my folder game

Code:
   <Set Name="LOTR" GUID="1610621569">
      <Setting Name="Lock Foreground">1</Setting>
      <Set Name="Profiles" GUID="1610621570">
         <Set Name="LOTR Default Profile" GUID="1610621571">
            <Setting Name="Game">LOTR</Setting>
            <Setting Name="Executable">TurbineInvoker.exe</Setting>
            <Setting Name="Parameters" />
            <Setting Name="Path">C:\Program Files (x86)\StandingStoneGames\The Lord of the Rings Online</Setting>
            <Setting Name="Preload Executable" />
            <Setting Name="Preload Parameters" />
            <Setting Name="Preload Path" />
            <Setting Name="Force Monitor">Application Controlled</Setting>
            <Setting Name="Loader">-1</Setting>
         </Set>
         <Set Name="LOTR No Patch" GUID="1610621572">
            <Setting Name="Game">LOTR</Setting>
            <Setting Name="Executable">TurbineLauncher.exe</Setting>
            <Setting Name="Parameters">-usetdm -invoker</Setting>
            <Setting Name="Path">C:\Program Files (x86)\StandingStoneGames\The Lord of the Rings Online</Setting>
         </Set>
         <Set Name="LOTR No Patch (Alternate)" GUID="1610621573">
            <Setting Name="Game">LOTR</Setting>
            <Setting Name="Executable">TurbineInvoker.exe</Setting>
            <Setting Name="Parameters">-usetdm</Setting>
            <Setting Name="Path">C:\Program Files (x86)\StandingStoneGames\The Lord of the Rings Online</Setting>
         </Set>
      </Set>


and since i did that, i can log 2 accounts almost regularly (1 account always on first try, second account ask for 3 or 4 tries). For the 3rd account there is message of timing out showing up now.

If you have any more idea, i am open to all

Thank you

update : after waiting some times and while still playing with two accounts, attempted to log the 3rd account and all good. I do not know if the change i made are good or not or if its only a coincidental time for logging, but at least it seems to work fine. I will have to redo those though each time i quit the game as the patcher erase the change each time
<<

lax

User avatar

Site Admin

Posts: 6914

Joined: Tue Nov 17, 2009 9:32 pm

Post Sun Nov 25, 2018 11:09 am

Re: LOTRO :still getting black screen after launch succeeded

Game Profiles other than the one you're using at the time are irrelevant, the ones that say "DDO" you can simply ignore.

If you have not yet tried the "legacy client" option in the LOTRO launcher settings, that is something else you can try.
<<

zoopsie

Posts: 34

Joined: Sun Feb 08, 2015 7:15 pm

Post Sun Nov 25, 2018 11:27 am

Re: LOTRO :still getting black screen after launch succeeded

lax wrote:Game Profiles other than the one you're using at the time are irrelevant, the ones that say "DDO" you can simply ignore.

If you have not yet tried the "legacy client" option in the LOTRO launcher settings, that is something else you can try.



ok will try that later (too happy to be in game now, so i will test that later this evening :P)

And thank you for all you do for trying to help me, it is very appreciated
<<

zoopsie

Posts: 34

Joined: Sun Feb 08, 2015 7:15 pm

Post Wed Nov 28, 2018 11:26 am

Re: LOTRO :still getting black screen after launch succeeded

Thank you very much for all the help.

Finally the last option *legacy client* did the trick completely. I can log in without any problem at any time with 3 accounts.

You really helped me a lot to not stress out too much, and now i can enjoy playing again.

Thank you very much for your patience and kindness
<<

Starrygirl

Posts: 5

Joined: Sun Jan 07, 2018 10:30 am

Post Sat Dec 08, 2018 12:02 pm

Re: LOTRO :still getting black screen after launch succeeded

Using the legacy option in the launcher worked for me as well, but it's annoying to not be able to use the store in game. Still no fix for the actual problem?
<<

lax

User avatar

Site Admin

Posts: 6914

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Dec 08, 2018 6:46 pm

Re: LOTRO :still getting black screen after launch succeeded

Starrygirl wrote:Still no fix for the actual problem?

No.

I do not currently have an ETA on "fix for the actual problem" as I have been very deep into other things.
<<

Starrygirl

Posts: 5

Joined: Sun Jan 07, 2018 10:30 am

Post Sun Dec 09, 2018 7:32 am

Re: LOTRO :still getting black screen after launch succeeded

Okay, thanks. Was just afraid I was missing some other fix or workaround. I know you have a lot of other games and "keeping up with game changes" to do.

On a brighter note, kudos to all you folks who created and keep this program running! I can't tell you how much joy my little musical hobbit herd has given me! (Did I ever mention the time I clicked 'use the mailbox' in Chamber of the Crossroads, forgetting I still had broadcast on, and they all unexpectedly ran across the room and jumped down the well? :lol: Still makes me laugh out loud to remember it, they were so cute, and I was 'Whaaaa?")

Thank you!!!
Previous

Return to Lord of the Rings Online

Who is online

Users browsing this forum: No registered users and 1 guest