Page 1 of 1

Innerspace does not connect over network since patch

PostPosted: Sun Apr 28, 2019 3:17 pm
by Manni
Innerspace had always slight problems to work for a longer period of time (4-5h+) stable in a 3-PC-network at my Win10 systems. My solution was always to use ISBoxer and export to all Innerspace Computers. That somehow resetted the connection and access from every PC to every PC was possible again. Since last update (I disabled updates due to earlier problems with newer version) it partly looses connection from the start or very early after some minutes. ISBoxer has the option to connect to other PCs (so it seems that ISBoxer finds the other ISBoxer) but the Uplink Console of Innerspace does not show any reaction.

The systems didn't changed except the usual updates of EQ, *** and this time also Innerspace/ISBoxer. The Installation of Win10 is pure, no other things installed than EQ, ***, Innerspace because of the trouble I had before.

Is there any way to simply click a connect button or force a reconnect other than with ISBoxer?

Re: Innerspace does not connect over network since patch

PostPosted: Sun Apr 28, 2019 5:33 pm
by bob
A relaunch of your team (right click the InnerSpace icon, select ISBoxer Character Sets -> your team name), would cause InnerSpace to attempt to reconnect to all other PCs if the character set has the Also Launch setup, and it is all working. If it fails to connect when doing this, then the issue of your intermittent network problems are not InnerSpace and rather your network or the PCs on it (or some software on those PCs).

Re: Innerspace does not connect over network since patch

PostPosted: Sun Apr 28, 2019 7:28 pm
by Manni
Your description is the standard way I load all toons. That does not work.
Why has Innerspace the problem and not ISBoxer, nor EQBCS?
ISBoxer recoqnizes different ISBoxers on other PC. EQBCS connects and handles reliably all data streams (that is the reason why I use it because Innerspace sporadically seized working before the patch after 4-5hours). File transfers via network works perfect. The setup is the same like before the patch. I have no firewall active, no antivirus, Win10 is installed with drivers, like before without any additional software. I didn't install anything because this is exclusively a EQ system.
Before EQ patch and Innerspace update it worked, after EQ patch it seized to work. Only using Innerspace/ISBoxer without *** does the same.
Configuration of Innerspace didn't change, all ports are the same like before, the names are the same like before.

Only Innerspace says that it cannot connect.

Isn't there another debugging possibility or a kind of connection log to check or another solution?

Re: Innerspace does not connect over network since patch

PostPosted: Mon Apr 29, 2019 10:45 am
by Manni
Sorry, didn't saw that little text and for me this is not a hack program if you use it like ISBoxer. And as long as Innerspace is not completely reliable and I don't get another solution then this is the only other option.
So I only got answers that I should not use this name here, so here my findings for others who have trouble and for Lax for optional bugsearch...

[x] Check with Advanced Port Scanner
-> no connection via port 10101
-> no connection via changed port 1024, 4899
-> possible bug: Innerspace does not change port number until closed and restarted

[no change] ISBoxer export into innerspace (PC3)
[no change] reboot of the system (countless times, after every change)
[no change] changed port number
[no change] fixed IP instead of DHCP
[no change] changed Innerspace 42xx, 43xx, 44xx
[no change] Innerspace: Admin mode
[no change] Innerspace: compatibility mode with Win7
[no change] Last Win10-Updates removed: KB4493509 for update 1809 deinstalled (changes since EQ-patch from the Windows side despite deactivated windows updates)
[no change] disabled DHCP/router after every system got his fixed IP to avoid interference + disconnected internet
[no change] changed physical ports of the switch (to avoid possible defects/problems)
[no change] included innerspace with all access rights explicitely, activated/deactivated firefall (useless, but an idea)
[x] installed Radmin-Server and client for testing
-> works on his usual port without problem -> ergo: port/innerspace problem
[no change] used some from port scanner as marked open ports (445)

[x] rebooted "old/never updated/full of installations" Win10 system, which made trouble a year ago -> connection with Advanced Port Scanner works on 10101 and 1024
[x] rebooted "newly installed EQ-only Win10 1809" + copied/replaced to version 6336 + started Innerspace with compatibility Win7 + admin mode + exported ISBoxer-config into Innerspace
-> Advanced Port Scanner can make a remote uplink but Innerspace cannot do it on themselves...arrrrg...
[does not work] started Innerspace on other system -> wrong port numbers accessed (10101) despite configuration of all Innerspace says portnumber 1024
[does not work] restarted ISBoxer and exported to Innerspace again.... still accessing at 10101 despite all systems show 1024... arrrrg..
[does not work] rebooted Win10 again, changed Innerspace (Win7 compatibility, admin mode), restarted - still connecting to 10101 while port scanner shows 1024... arrg...
[does not work] rebooted ALL PCs again
[does not work] replaced all Innerspace to version 6336
[export works -> connect through ISB is there] exported to all PCs from ISBoxer
[does not work] loading through Innerspace -> uses port 10101 despite Advanced Port Scanner uses 1024, ISBoxer can connect, only Innerspace is unable to make what he should!
[does not work] Deinstalled Innerspace/ISBoxer, reboot Win10, fresh install of ISB/IS to latest version, export config file to IS
-> no contact from ISBoxer over the net anymore
-> not even contact via Advanced Port Monitor after fresh install is possible....arrrg....
[does not work] reboot Win10 again
[x partly] renamed fresh installed ISB/IS V64xx and renamed/replaced with folder 6336
-> Innerspace is accessible through Advanced Port Monitor again at port 1024 (all are configured like that) = PC3
-> Innerspace tested on second PC (PC2) - connect from outside through Advanced Port Monitor at 1024 ok
[not working] Innerspace starting characterset -> want to connect through that darn port 10101 again ... ARRRRRG.. never had such a sturdy piece of software
[x] Reconfiguration of all Innerspace back to port 10101
-> Connect via Advanced Port Monitor works at 10101 on PC2 and PC3
-> Connect via ISBoxer works
-> Connect via Innerspace works now -> starting character set

I don't know how long that will work but after hours of wasting time with different tries, two PCs at least start to connect.

Innerspace has some serious issues sometimes.
I am staying at moment at V6336 and avoid updating again to V64xx. Hopefully that will solve it. Never change a running system - I should have known it.
But perhaps Lax can read something out of the above tries.

- fixed IPs, no DHCP
- compatibility: admin mode & Win7 compatibility
- Version 6336
- Port 10101

Issues with questionmarks:
- cannot change port number (e.g. to 1024, was only for testing purposes, not necessary)
- strange sporadic non-connectivity while other software packs can use different ports and can even access Innerspace directly successfully
- innerspace seems to loose sometimes some information, after export from ISB it runs for a bit of time again

Re: Innerspace does not connect over network since patch

PostPosted: Tue Apr 30, 2019 8:53 am
by lax
I do find it hard to follow that. There's a lot of extraneous information that I have to skim over, while certain details such as the specific "64xx" build number are left out.

1. Why are you using Windows 7 compatibility mode on Inner Space? Have you tried without it? We do not recommend using any Windows compatibility mode, as this is almost guaranteed to break parts of Inner Space. If we're looking for differences between you (with it broken) and everyone else (with it working), this would seem to be something ...

2. To answer your question regarding "possible bug", you are correct that changing the Uplink name or port info requires a restart of Inner Space, as does initially enabling uplink connections. You would also need to update your ISBoxer Toolkit settings to match.

3. Have you tried the development build of Inner Space? Now on 6430. As you've only mentioned 6336 and "64xx" I can only assume you've only tried builds 6336 and build 6423.

4. There's been several live updates between 6336 and 6423, and dozens of development builds. All of these builds are available. If you want me to look at a particular change to Inner Space to try to understand your issue better, it would help to narrow it down a bit more than 6336 vs "64xx". To install a particular Inner Space version, press Windows+R and put in
"%ProgramData%\Lavish Software\utils\LavishBuild" install innerspace live "1.16 build ####"

Put the build number in place of the ####.

Also, this thread belongs in the Multiple Computers section as it seems to be unrelated to EverQuest (other than that you happen to want to play EverQuest with ISBoxer).

Re: Innerspace does not connect over network since patch

PostPosted: Thu May 02, 2019 4:53 pm
by bob
To expand on item 2.

This setting is for each computers InnerSpace listening port. Yes, after changing you need to exit and restart InnerSpace.

This setting is used by the initiating InnerSpace as the destination port for this computer. i.e. InnerSpace will attempt to connect to this port when trying to communicate with this computer (and yes, I selected the other computer than the listener ss).

So if you change the InnerSpace setting on a computer, you need to also change the ISBoxer Toolkit profile for that computer, and export that profile.

DHCP/DNS name lookup is sometimes a bit flakey on a home network depending on the router. I certainly know my home router is crap for this as it caches the table for a long time, and the computer can end up with a different address, and a DNS lookup can fail. Fixed IP, and IP specified in the toolkit settings is much more reliable.

Also be wary of Windows Firewall settings. You should ensure that you have opened the applicable ports for the listening computers. You should also confirm which profile this is done for and whether the desired NIC is using this category, because it is not unknown for Windows to switch the network category from Private to Public, uninvited, and thus bring in more restrictive firewall rules (you appear to mention this in your testing anyway, but figured I'd spell it out).