FAQ  •  Register  •  Login

ISBoxer is constantly activating the wrong window

Moderator: MiRai

<<

Golgoret

Posts: 2

Joined: Fri Feb 09, 2018 9:03 pm

Post Fri Feb 09, 2018 9:10 pm

ISBoxer is constantly activating the wrong window

I've been having a problem with ISBoxer recently and I have no idea how to even begin fixing it. I use two monitors, with one player on my left screen, and all my other guys tiled on the other screen. Randomly, when I am using the mouse on my main screen, the game will begin acting as though I hovered over one of the other windows, even though I never did. Meaning I will be moving around and using the mouse, and all the sudden the window on the left monitor drops down to 30 FPS (because it is now being interpreted as "in the background") and all input is sent to one of my other windows, as though I had hovered over the window and started typing. During the entire time, the mouse was completely within the next monitor, I never moused over any of the other windows, but ISBoxer thinks I did.

This happens every 2-3 minutes, has become very frustrating, and kills me frequently because the game stops responding to input. I have no idea how to investigate why ISBoxer is incorrectly sending input to the wrong window, so I'm wondering if i can eliminate the problem entirely by taking a different approach. Is there a way I can configure ISBoxer so that it does absolutely nothing when I hover over my other EQ windows? If I want to enter input on a specific window, I will just switch to it. I want mouse input to go to whatever is the "main" window no matter what.
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 2982

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sat Feb 10, 2018 4:02 am

Re: ISBoxer is constantly activating the wrong window

ISBoxer normally does not change focus via the mouse hovering, unless it has been configured to do so. This is an option on your Window Layout called "Focus game windows via mouse without clicking (Focus follows mouse)". If you have this ticked, you should untick it.
If you are using a VideoFX layout, this will be force enabled, and you can't change that.

Another Window Layout option to check is the "Swap Hot Character to main region" option, although from your own words, you are not getting any swapping action going on, but if you had this set to "any time ISBoxer focuses a window", you would indeed see the swapping, if it was in fact ISBoxer doing the focussing.

The other thing to potentially look for, is on each slot number in the character set, there is a "Hotkey to switch to this character". What is this set to?, are you inadvertently pressing this combo?. If it is set to Global, untick this option. If you happen to have a gaming keyboard and are making use of its "special" macro keys, some keyboards, unless set correctly, can actually end up sending extra key presses you might not be aware of.

Also, while you're at it, have a look in the Key Map, ISB42 - Always On. In there is a Next Window/Prev Window set of mapped keys. Do they have hotkeys? Are you pressing these perhaps?.

Within ISBoxer itself, ingame you can bring up the UI with CTRL+ALT+SHIFT+G (def hotkey), and under the debug tab, you can set some options to track what is being pressed and/or sent to each Window. You may be able to garner some info here when the swapping of input takes place.

And probably finally, it does matter a little bit on your config. If you have a "pro" config, with a lot of virtualization taking place, it is possible that you may have something not configured correctly.

Oh, and it might matter what else is running on your machine. Other tools have been known to cause odd behaviour.
<<

Golgoret

Posts: 2

Joined: Fri Feb 09, 2018 9:03 pm

Post Sun Feb 11, 2018 6:31 am

Re: ISBoxer is constantly activating the wrong window

Thanks for the response, I'll check this stuff out. I was fiddling around with it more today. What seems to happen is different than what I originally thought. My main window is losing focus, but it isn't losing it to another game window...it's losing it to the VideoFX window itself. When I get into this state, if I hold down Alt-Tab to see what order windows has layered my windows, I see that the currently selected window is the VideoFX window. It's weird to me that the VideoFX window itself would ever receive focus, I would expect it to be one of my EQ instances. Regarding your other suggestions, some notes:

1. The "hotkey to switch to this character" settings I use are all fairly benign. They are complex key strokes that are impossible to trigger without deliberately doing it. Some of them are global which I will probably turn off, but the game isn't actually switching to a different EQ instance right now
2. No custom keyboard or mouse is involved. I currently use a standard keyboard and while I DO use a logitech gaming mouse, this problem was happening even when I used a standard 2 button cheap mouse that had no fancy software at all
3. My "next/previous window" keys are also highly complex and not something I could hit accidentally
4. While it is possible there is something else on my system doing this, I don't normally have windows lose focus with any other programs I use, only with ISBoxer
5. I'll turn on the debug display and see if it gives me any clues what is happening here.

Any ideas about types of settings which would cause the VideoFX window to receive focus when the mouse is in the other window?
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 2982

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sun Feb 11, 2018 3:46 pm

Re: ISBoxer is constantly activating the wrong window

I'm still not 100% you are running a videofx layout, but based on what you've said, lets assume you are.

With a VideoFX layout, it actually runs a stacked set of games where your active window is. The only thing I can think of currently, that would exhibit the behaviour described, is you've set your regions "Always On Top Mode" to ON. By default a VFX Layout sets this to "On, if a game window is foreground". IMO, it should probably be set to Off, but, that is based on my uninformed knowledge of what actually is going on behind the scenes.

Return to EverQuest

Who is online

Users browsing this forum: No registered users and 3 guests