FAQ  •  Register  •  Login

Keyboard Overlay problem

Moderator: MiRai

<<

Restgamer

Posts: 8

Joined: Sat Mar 15, 2014 3:11 pm

Post Fri Oct 23, 2015 10:37 pm

Keyboard Overlay problem

I just followed MiRai's tuturial on how to setup an keybord Overlay: https://www.youtube.com/watch?v=-AmjRFjgWoo
I got pretty much all to work, but the shift and space key is not working. I dont know why. they work when i press them with my mouse, but not when i press them on my keyboard.
Also the "|" key (next to 1) is also not working. Im guesing it might be becouse im using an european verion.

Hope someone can help, thx ^^
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3191

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sat Oct 24, 2015 4:07 am

Re: Keyboard Overlay problem

Define "european version". I use a "European version" keyboard myself, the British one, but it is very different to some other "European version" keyboards, like the Duestch, Finnish and French setups.

On my keyboard, the | key is actually down by the Z key. The key up by the 1 key has ¦ which is a different character totally, and this particular physical key is like other European keyboards where you have 3 characters, ` ¬ ¦ on it (in order of natural/Shift/AltGr). Getting the third character requires the AltGR key. On a US keyboard the key next to the 1 key tends to be ` ~ when using the ANSI layout, so the backtick should work as a trigger, but the dbl pipe is not normally on a US layout at all.

Anyway, it depends on the keycode which is sent, because the same keycode (which gets turned into a virtual keycode) can output different results depending on which keyboard layout you have loaded, but which keycode is sent for a given physical key is usually defined by the manufacturer, although Left Shift and Space are usually generic so it is a little weird.

If you use the ISBoxer in game gui (CTRL+SHIT+ALT+G) goto the debug tab, do Show Debug Console, make sure the Button option is selected, turn on Repeater (broadcasting), and then press/release Left Shift and Space. Then switch to another window, and have a read of the output in the window. It should have something like the following.
Code:
Button: from repeater@is1: hold SHIFT
Button: from repeater@is1: release SHIFT
Button: from repeater@is1: release LEFT SHIFT
Button: from repeater@is1: hold SPACE
Button: from repeater@is1: release SPACE
<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Oct 24, 2015 7:51 am

Re: Keyboard Overlay problem

The issue sounds like a language issue.

If you are putting "shift" in the file and you are using a French keyboard, the key is MAJ, not SHIFT. I believe SPACE is also not "space". For a list of valid key names for you, open up an IS console (e.g. right click IS and select Console) and put in the command "bind -keylist".

If you need further help with this, please share what you have created (e.g. on http://pastebin.com, or attach a file to your post, etc) and be absolutely specific as far as what input language is active in Windows.
<<

Restgamer

Posts: 8

Joined: Sat Mar 15, 2014 3:11 pm

Post Sat Oct 24, 2015 8:11 am

Re: Keyboard Overlay problem

Im using a norwgian keybord and Windows language
Will paste settings when i get home
<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Oct 24, 2015 8:20 am

Re: Keyboard Overlay problem

1. Shift should be SKIFT
2. Space should be MELLOMROM
3. "|" (key left of 1) should work fine. I can do some testing on that. But make sure in your switch case in the iss file you don't have extra spacing or quoting at the end, it should just say "case |"
<<

Restgamer

Posts: 8

Joined: Sat Mar 15, 2014 3:11 pm

Post Sat Oct 24, 2015 9:54 am

Re: Keyboard Overlay problem

Got it working now thx alot!

Return to Menus

Who is online

Users browsing this forum: No registered users and 1 guest