FAQ  •  Register  •  Login

interact with target issue

Moderators: MiRai, Binzyrd

<<

mohal

Posts: 55

Joined: Wed Apr 04, 2012 10:10 pm

Post Thu May 31, 2012 5:40 am

interact with target issue

i have 4 toons, and they were all working great, but somehow now one of the 4 gives the wrong codes through when i want to interact with a friendly target. i get the invalid target or you have no target message. when i use one of the other 3 first, everything works fine. i deleted the config.wtf of the toon in question, that did not help. any suggestion?
edit: the screen swap is not working anymore either, at least, not all the time. isboxer is running on all 4. because they are all mages (i know very little about this class, so i am experimenting) i am using the same settings for all.
the defect toon gives the follow command through normally.
<<

lax

User avatar

Site Admin

Posts: 5339

Joined: Tue Nov 17, 2009 9:32 pm

Post Thu May 31, 2012 7:42 am

Re: interact with target issue

Sounds more like Assist isn't working in that window? Possibly this FAQ: I recently set a key binding in the game and now assist doesn't work? (you'll check that specific window)

edit: the screen swap is not working anymore either, at least, not all the time. isboxer is running on all 4. because they are all mages (i know very little about this class, so i am experimenting) i am using the same settings for all.
the defect toon gives the follow command through normally.

When did this start? To help with this part I might need to see your config. HOWTO: Share your configuration for better support
<<

mohal

Posts: 55

Joined: Wed Apr 04, 2012 10:10 pm

Post Thu May 31, 2012 7:59 am

Re: interact with target issue

option 1 did not work, so here is my config link
http://www.privatepaste.com/9b01043e37. thanks for your time.
<<

mohal

Posts: 55

Joined: Wed Apr 04, 2012 10:10 pm

Post Fri Jun 01, 2012 3:28 pm

Re: interact with target issue

anybody? i created another set with the same toons, and got the same results. turning the keybindings to defaults did not help either. i had already tried deleting the wtf file, so what else is there?
<<

lax

User avatar

Site Admin

Posts: 5339

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Jun 02, 2012 7:07 am

Re: interact with target issue

The Config.WTF file should have zero effect on this issue -- it stores your account name for login, and video/sound type of settings.



There's at least one big fat glaring problem with resetting your WoW key bindings to default: your IWT key configured in ISBoxer is Space. If you have not re-configured the IWT key binding in the game in that window, it will not have a key binding at all and Space is Jump. So I would expect that toon to jump when the rest IWT.

The other things that you should check are right back in the Quick Start Guide(s)... I'd kind of have to say to start here WoW Quicker Start Guide, Part 3: Make sure the ISBoxer Addon is not disabled and follow it to the end (bearing in mind that your Follow key is F rather than Alt+F, etc). I don't expect this to be the problem because you told me your guy will still follow, but this is the only thing besides making sure the buttons you configured in ISBoxer match the game's configuration in that window.


As far as your Window Layout, I assume we're talking about "a_aggra_4mages". What sticks out to me about this Window Layout is that Region 2 is not the same size as the other small windows. While the others are 480x260 in size, this one is 463x260. You can have this team re-use another Window Layout if you like, such as h4_palpode, which it looks like this new Window Layout is supposed to match.
<<

mohal

Posts: 55

Joined: Wed Apr 04, 2012 10:10 pm

Post Sat Jun 02, 2012 6:17 pm

Re: interact with target issue

What i do not understand is what happened that made it stop working. i have used space as iwt since the beginning with no problem at all. of course isboxer is running on all 4 toons. i will change the window size and see what that does.
if nothing works, what should i do to start from scratch? delete and reinstall everything in a clean directory? or are there specific files that i could delete and recreate a character set with the same toons?
edit: i seem to have the same problem with at least another character set, but the problem is not from the same account. i know there has been patches recently, and i have no idea if it is related, but the fact that the problem suddenly appears is baffling. it is also erratic because now one of the toons sometimes, but rarely, reacts normally to the iwt call, while the other 2 give the invalid target message.
<<

lax

User avatar

Site Admin

Posts: 5339

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat Jun 02, 2012 7:06 pm

Re: interact with target issue

i have used space as iwt since the beginning with no problem at all

You should have no problem continuing to use Space for IWT, that's not what I'm saying.

What I am telling you is simply that you told me that you reset your WoW Key Bindings in the game... which means that -- when you do this -- IWT is not set to Space anymore in that window, it is set to nothing because it has no hotkey by default. Unless you configured it back to Space in that window, it's not going to work.

When you press Space in window 1, then -- as configured -- windows 2 3 and 4 should get Shift+Alt+N, then Left Shift+Backspace, then Space.
Shift+Alt+N should make sure Click to Move is enabled, then Left Shift+Backspace should cause it to /assist the guy in window 1, then Space should cause it to Interact with Target. You can test each of those things in Window 4 right now.

Another thing you can do is look at the in-game debugging console to see what keys the game is receiving, and from where. Press Ctrl+Shift+Alt+G, click the debug tab, and tick the "Buttons" box. Then click "Show Debugging Console". Now when you send buttons to any window via Mapped Keys or broadcasting, it will tell you about it in this little box. So, press Space and then look at the debugging console in each window. It should show output matching the keys sent by your Mapped Key.


if nothing works, what should i do to start from scratch? delete and reinstall everything in a clean directory? or are there specific files that i could delete and recreate a character set with the same toons?

You don't actually have to delete anything. You can just go to File, Save As, and save your profile as something else. Then go to File, Clear. Then run the wizard again, and your ISBoxer configuration will be back in a known-good state.

But if you do this, it's still going to set up pretty much the same thing you have right now, minus a bunch of teams and a handful of custom Mapped Keys and Hotkeys. I am not sure this is going to solve the problem you are having.

Sometimes it's another addon causing a problem. For example some people don't realize that they made some Hotkey in Bartender that isn't listed. Then if I get them to do the Assist fix (which I linked you earlier and you said did not work) and they set something unbound to, say, Shift+Backspace or Ctrl+Shift+Backspace, then WoW will say what it was bound to. And then they say "oh... I looked through the list but didn't see anything configured to backspace but apparently my addon had something". So... just saying, the instructions tell you to do that for a reason. ;)
<<

mohal

Posts: 55

Joined: Wed Apr 04, 2012 10:10 pm

Post Sun Jun 03, 2012 6:42 am

Re: interact with target issue

i disabled all the addons but isboxer. no change. i used the debug tool and i am afraid i somehow made things worse. now iwt is not working at all, for none of the toons. i defined an used key with all variations of space (modifiers), the only message i got was when i use space only, that iwt was unbound. put it back on again of course., but when i use it now, i get the talents screen (default N) on the "defect toon", and first no reaction at all with the others, but now the expected target screen... and the talents screen. please tell me wich info in the debug log would be relevant, because as far as i can see, there are no differences between what appears on the different screens. its all a variation of:
button: from variablekeystroke@is2: nomodifiers 160+164+N
button: from variablekeystroke@is3: nomodifiers ctrl+bcksp
button: from variablekeystroke@is3: nomodifiers space
with the only difference being the @isx

edit: the only clue i got so far is when i try to redefine backspace. i get click ftl assist left button is now unbound. except on the defect toon. but unbinding the backsp on that toon does not help. i can bind it to any key i want, no reaction.
<<

lax

User avatar

Site Admin

Posts: 5339

Joined: Tue Nov 17, 2009 9:32 pm

Post Sun Jun 03, 2012 7:12 am

Re: interact with target issue

please tell me wich info in the debug log would be relevant, because as far as i can see, there are no differences between what appears on the different screens. its all a variation of:
button: from variablekeystroke@is2: nomodifiers 160+164+N
button: from variablekeystroke@is3: nomodifiers ctrl+bcksp
button: from variablekeystroke@is3: nomodifiers space
with the only difference being the @isx


Right... that's the only difference when you hit it from different windows, is what window it comes from and what modifiers are passed with Backspace in order to perform the Assist. From window 1 it would be left shift+backspace, from window 2 it's right shift+backspace, from window 3 it's ctrl+backspace, and from window 4 it's alt+backspace. But, you did part of what I asked so I am proud of you -- you have confirmed that ISBoxer is doing what it's supposed to do, AND that the problem is indeed entirely (100%) in your WoW configuration (no changes in ISBoxer are necessary).

but when i use it now, i get the talents screen (default N) on the "defect toon"

That means this same thing should happen if you go to that screen and press Shift+Alt+N yourself instead of ISBoxer pressing it. (This is why I asked you to do that...)

Note that Shift+Alt+N, per your ISBoxer config, should be configured with a macro that enables Click to Move. The fact that that does NOT happen, but rather Shift+Alt are ignored and your Talents window (bound to "N") opens up, tells me that there is no Key Binding configured to Shift+Alt+N in that window, because the ISBoxer Addon is not enabled in that window.

So I guess we're at an impasse here because you've already sworn to me multiple times that the ISBoxer Addon is enabled in that window so this must not be the problem. . . . . . . so there's a couple possibilities I will mention:
1. If you're not actually using ISBoxer with this team when you click the Addons button and look at window 4 to see if the ISBoxer Addon is enabled... then the actually-loaded Addons might not match
2. If you're managing to run ISBoxer as Administrator but not Inner Space, then ISBoxer could be saving the ISBoxer Addon to the actual WoW folder and WoW could be looking for it in your Windows "Virtual Store" instead of in the WoW folder. (This is only relevant if you're using Vista or later, with WoW installed to the Program Files folder)

That's about it. To recap, Shift+Alt+N opens the talent window because the macro that the ISBoxer Addon installs isn't there, which means the ISBoxer Addon is most likely NOT loaded in that window.



Edit:
edit: the only clue i got so far is when i try to redefine backspace. i get click ftl assist left button is now unbound. except on the defect toon. but unbinding the backsp on that toon does not help. i can bind it to any key i want, no reaction.

Same thing I've described above. The macro is not bound in that window because the ISBoxer Addon is not loaded.
<<

mohal

Posts: 55

Joined: Wed Apr 04, 2012 10:10 pm

Post Sun Jun 03, 2012 12:55 pm

Re: interact with target issue

Lax, i should buy you a gun so that you could shoot me. i rechecked the account, and not isboxer but zygor was enabled. i do not know if that was the case all the time, or that i disabled the wrong one when you told me it could come from an addon. or that i disabled it somehow before. no idea, and i am just glad it is working again. sorry for all the fuss and thank you very much for your patience.

edit: i know now that it probably was not me that disabled isboxer but that is a "bug" put in by blizzard.
Last edited by mohal on Sun Sep 23, 2012 2:20 pm, edited 1 time in total.
Next

Return to World of Warcraft

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests