FAQ  •  Register  •  Login

HELP! Inner space not working

Moderator: MiRai

<<

gankishkhan

Posts: 13

Joined: Sun Sep 10, 2017 3:40 pm

Post Tue Sep 12, 2017 6:48 am

Re: HELP! Inner space not working

bob wrote:The diagnostic didn't show much that was different than the previous, which isn't completely unexpected. The error number is INAVLID_IMAGE_FORMAT, and is most often caused by an incorrect DLL loading, i.e. a 32bit DLL loading into a 64bit process or something along those lines. It migt also just be a corrupted file.

Things to try
  1. Reboot your computer if you haven't already
  2. Reinstalling InnerSpace.
  3. Set an exclude in Nortons (your AV?) on InnerSpace.exe and WoW.exe and WoW-64.exe
  4. Reinstalling Direct X
  5. Try the .NET repair tool (for .net35)
  6. Update Windows
  7. Reinstall the game


Thanks Bob. I'll try these things tonight after work and report back.
<<

gankishkhan

Posts: 13

Joined: Sun Sep 10, 2017 3:40 pm

Post Tue Sep 12, 2017 8:26 pm

Re: HELP! Inner space not working

Okay, so I did everything on the list except reinstall the game (last resort). None of them worked.

Next I'm going to pull out the 1080ti and put back in the 780gtx to test compatibility.

In the meantime, here is a SS of innerspace console right after trying to launch.

UPDATE: swapping video cards had no affect. Still no launchy launchy. I guess I'll try reinstalling the game ...


innerspace SS.gif
innerspace SS.gif (221.76 KiB) Viewed 58 times
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 2611

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Wed Sep 13, 2017 3:31 am

Re: HELP! Inner space not working

Thanks for the image. I was after what IS was trying to launch.
If you look under the Inner Space configuration option, what are the settings of the Use 64-bit Inner Space Uplink and Use same-bit game clients. Seeing as it is launching WoW-64.exe, both those options should have a red dot. If you need to change them, exit and relaunch Inner Space.

Have you tested whether running the 32bit WoW works? What about the dx9 game profile?
You could just delete the WoW-64.exe and then re-patch. it should redownload just the exe, although if it is a dependency it is failing on, then that might not fix it.


/edit: It was pointed out that this particular one last came up with someone running Nortons. I know I suggested an exclude, and this should be set in the real-time scanning function if you do that, but this is not a full test. To completely rule it out, you need to uninstall it altogether and see if it still breaks without it. Unfortunately disabling and excluding does not stop the AV filter drivers from interrogating and potentially adjusting the program as they are hooked deep in the Windows Kernel. You may need to do this so we can rule it out from being the cause.

This article from MS, while long, explains some stuff about filter drivers and then in a small bit of text explains....
KB816071 wrote:Most antivirus software uses filter drivers that work together with a service to scan for viruses. These filter drivers are still loaded after the service is deactivated. These filter drivers scan files as they are opened and closed on a hard disk. For troubleshooting purposes, temporarily remove the antivirus software
<<

gankishkhan

Posts: 13

Joined: Sun Sep 10, 2017 3:40 pm

Post Wed Sep 13, 2017 5:51 pm

Re: HELP! Inner space not working

Uninstalling/reinstalling the game did not help.

I uninstalled Norton...and also saw Mcafee in there too, so uninstalled it also. I also disabled Windows 10 security features. Rebooted. Nope - no help.

At this point I'm going to take the hint from the computer Gods and do a complete format/reinstall of Windows 7; take the opportunity to add a couple 1tb SSDs for backup that I've been needing and go from there.

I appreciate the time and thought that you've put into this. If it still isn't working after I do those things I'll make a small thermite device and take care of it all in the back yard. :mrgreen:
Previous

Return to World of Warcraft

Who is online

Users browsing this forum: No registered users and 8 guests