FAQ  •  Register  •  Login

SWTOR will not launch after new update

Moderator: MiRai

<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Sun Feb 25, 2018 11:55 am

Re: SWTOR will not launch after new update

This is a good time to mention for you folks -- this issue does not occur for everyone.

If you want to come by the ISBoxer Discord (linked previously in this thread) you can drop in the #star_wars_the_old_republic channel and see what others have done to solve the issue for them. One says build 6180 from the Inner Space archives (https://www.lavishsoft.com/innerspace/archives/) works for him, another says build 6174 works and he didn't try 6180, and another says he disabled Kaspersky Internet Security (luckily, Kaspersky should be avoided anyway) and his issue went away.

There have been compatibility updates to Inner Space since this issue began, and I am still working to resolve remaining issues.
<<

Lee Von

Posts: 11

Joined: Thu Aug 28, 2014 11:23 pm

Post Mon Feb 26, 2018 3:03 am

Re: SWTOR will not launch after new update

I'll try and get on Discord sometime shortly if possible

Here is my compatibility diagnostics https://pastebin.com/xsR7Tbzq I followed MiRai's video but if I did it wrong please let me know

I had some time to do some testing earlier and for me it could sometimes take 20-30 times to launch a slot, whereas if lucky it would only take a couple of tries. When launching a slot 1 of 4 things occurred. Number 3 is what happens the majority of the time. Happy to provide more testing/logs if needed.

1. Launcher loads and allows for logging in and then clicking on play successfully launches the game
2. Launcher loads as a background process but does not come forward as an app so unable to login. Need to kill the process.
3. Launcher loads to the login screen however after entering credentials it just sits there with the blue spinning loading screen on the launcher continuously
4. Launcher loads but to the white screen as shown in lazygirl's post
Image
<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Tue Feb 27, 2018 5:41 pm

Re: SWTOR will not launch after new update

Thanks

Inner Space build 6256 is up now as a development build, and this should specifically help with the SWTOR launcher. To try it out, right click Inner Space and select Patcher, tick "Download development (test) patches" and then close and restart Inner Space to let it patch up. Let me know :)
<<

Lee Von

Posts: 11

Joined: Thu Aug 28, 2014 11:23 pm

Post Wed Feb 28, 2018 5:58 am

Re: SWTOR will not launch after new update

I was able to just do a quick test Lax and it worked like a charm. I'll have a better chance to do more testing over the weekend but so far so good :)
<<

Lee Von

Posts: 11

Joined: Thu Aug 28, 2014 11:23 pm

Post Thu Mar 01, 2018 7:50 am

Re: SWTOR will not launch after new update

Unfortunately it is no longer working after the latest development patch Build 6257. It has reverted back to what it was previously doing.

Is it possible to download previous development builds at all?
<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Thu Mar 01, 2018 8:38 am

Re: SWTOR will not launch after new update

Lee Von wrote:Unfortunately it is no longer working after the latest development patch Build 6257. It has reverted back to what it was previously doing.

Is it possible to download previous development builds at all?

No, however the same behavior should still be active. Otherwise, please try the new option as described: http://isboxer.com/forum/viewtopic.php?f=22&t=9092
<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Fri Mar 02, 2018 7:32 am

Re: SWTOR will not launch after new update

I was hoping for further feedback on that, but I will have a new dev build today to correct further issues
<<

lax

User avatar

Site Admin

Posts: 6885

Joined: Tue Nov 17, 2009 9:32 pm

Post Mon Mar 05, 2018 7:56 pm

Re: SWTOR will not launch after new update

Inner Space build 6258, now the development build of Inner Space, should correct the several issues that affected the SWTOR launcher, including ...
1. Freezing during process initialization
2. An internal "timeout waiting for the window" error (in the SWTOR launcher) that would close the SWTOR launcher with no message
3. Loading the web page without styles (white browser page, most links are just text instead of clickable, etc -- as screenshotted in this thread)

To try it out, right click Inner Space and select Patcher, tick "Download development (test) patches" and then close and restart Inner Space to let it patch up. Once again, let me know! :)

p.s. We're also on Discord, please feel free to find us at there! https://discord.me/isboxer
Previous

Return to Star Wars: The Old Republic

Who is online

Users browsing this forum: No registered users and 2 guests