FAQ  •  Register  •  Login

SWTOR will not launch after new update

Moderator: MiRai

<<

MiRai

User avatar

Vibrant Videographer

Posts: 2702

Joined: Fri Nov 20, 2009 3:30 pm

Post Mon Dec 18, 2017 12:53 am

Re: SWTOR will not launch after new update

lazygirl wrote:Just tried this. No change.

I would start by removing the compatibility on the exe:
Code:
0 D:\Electronic Arts\BioWare\Star Wars - The Old Republic\launcher.exe: ~ DISABLEDXMAXIMIZEDWINDOWEDMODE


If that doesn't change anything, then I would shut down the following, non-essential processes (the list scrolls):
Code:
38. dokanmnt.exe - Process ID: 4144 (C:\Program Files (x86)\PogoplugBackup\dokanmnt.exe) [Admin:NO] [x64] [GENERIC - 4.5.5.26] [Cloud Engines] [DokanCE Mounter]

45. ForwardDaemon.exe - Process ID: 3272 (C:\Program Files (x86)\Motorola\MotForwardDaemon\ForwardDaemon.exe) [Admin:NO] [x86] [1, 0, 0, 0] [Motorola] [ForwardDemon]
46. GameScannerService.exe - Process ID: 4084 (C:\Program Files (x86)\Razer\Razer Services\GSS\GameScannerService.exe) [Admin:NO] [x86] [1.0.6.2673] [GameScannerService]
47. hbadmin.exe - Process ID: 4020 (C:\Program Files (x86)\PogoplugRemoteAccess2016\HBADMIN.EXE) [Admin:NO] [x64] [PPDRIVE - 4.5.5.32] [Cloud Engines, Inc.] [Pogoplug Remote Access Helper]

50. ioloGovernor64.exe - Process ID: 6972 (C:\Program Files (x86)\System Mechanic\iologovernor64.exe) [Admin:YES] [x64] [16.5.0.123] [iolo technologies, LLC] [iolo Process Governor]

58. MotoHelperAgent.exe - Process ID: 7272 (C:\Program Files (x86)\Motorola Mobility\Motorola Device Manager\MotoHelperAgent.exe) [Admin:NO] [x86] [14, 8, 6, 1] [Motorola Mobility LLC] [MotoHelperAgent]
59. MotoHelperService.exe - Process ID: 3584 (C:\Program Files (x86)\Motorola Mobility\Motorola Device Manager\MotoHelperService.exe) [Admin:NO] [x86] [2, 3, 8, 0] [Motorola Mobility LLC] [MotoHelper Service]

74. RzSDKService.exe - Process ID: 3992 (C:\Program Files (x86)\Razer Chroma SDK\bin\RzSDKService.exe) [Admin:NO] [x86] [1.0.7.1] [Razer Inc.] [Razer Chroma SDK Service]

160. Wacom_Tablet.exe - Process ID: 9408 (C:\Program Files\Tablet\Wacom\Wacom_Tablet.exe) [Admin:NO] [x64] [6.3.16-2] [Wacom Technology, Corp.] [Tablet Service for professional driver]
161. Wacom_TabletUser.exe - Process ID: 7712 (C:\Program Files\Tablet\Wacom\Wacom_TabletUser.exe) [Admin:NO] [x64] [6.3.16-2] [Wacom Technology, Corp.] [Tablet user module for professional driver]
162. Wacom_TouchUser.exe - Process ID: 9576 (C:\Program Files\Tablet\Wacom\Wacom_TouchUser.exe) [Admin:YES] [x64] [6.3.16-2] [Wacom Technology, Corp.] [Touch User Mode Driver]
163. WacomHost.exe - Process ID: 9264 (C:\Program Files\Tablet\Wacom\WacomHost.exe) [Admin:NO] [x86] [1.0.0.2] [Wacom Technology] [Wacom Load Agent]
<<

lunacybooth

Posts: 2

Joined: Tue Dec 19, 2017 4:07 pm

Post Tue Dec 19, 2017 4:19 pm

Re: SWTOR will not launch after new update

Hi, I'm experiencing similar problems as lazygirl, such as the launcher screen not displaying correctly, although I can usually get the launcher to run properly.
However after I enter my details and press the login button in the launcher, it usually hangs and wont go no further. I've checked the launcher logs in the game directory and have noted an error message :

Code:
ERROR JavaScript Error: Uncaught ReferenceError: JSONs is not defined
URL: http://127.0.0.1:53052/app/phoenix/src/model/settings.js
Line Number: 1


This error is not present if I launch the game without innerspace running.

Note this is a clean game install and while troubleshooting I have reinstalled innerspace. No other games seem affected (EVE online and WOW run fine with innerspace)
<<

MiRai

User avatar

Vibrant Videographer

Posts: 2702

Joined: Fri Nov 20, 2009 3:30 pm

Post Tue Dec 19, 2017 4:41 pm

Re: SWTOR will not launch after new update

lunacybooth wrote:Hi, I'm experiencing similar problems as lazygirl, such as the launcher screen not displaying correctly, although I can usually get the launcher to run properly.
However after I enter my details and press the login button in the launcher, it usually hangs and wont go no further. I've checked the launcher logs in the game directory and have noted an error message :

Code:
ERROR JavaScript Error: Uncaught ReferenceError: JSONs is not defined
URL: http://127.0.0.1:53052/app/phoenix/src/model/settings.js
Line Number: 1


This error is not present if I launch the game without innerspace running.

Note this is a clean game install and while troubleshooting I have reinstalled innerspace. No other games seem affected (EVE online and WOW run fine with innerspace)

I believe Lax is currently investigating this issue.
<<

lax

User avatar

Site Admin

Posts: 6912

Joined: Tue Nov 17, 2009 9:32 pm

Post Wed Dec 20, 2017 6:25 am

Re: SWTOR will not launch after new update

lunacybooth wrote:Hi, I'm experiencing similar problems as lazygirl, such as the launcher screen not displaying correctly, although I can usually get the launcher to run properly.
However after I enter my details and press the login button in the launcher, it usually hangs and wont go no further. I've checked the launcher logs in the game directory and have noted an error message :

Code:
ERROR JavaScript Error: Uncaught ReferenceError: JSONs is not defined
URL: http://127.0.0.1:53052/app/phoenix/src/model/settings.js
Line Number: 1

I have managed to get this same issue, however it only happens about 1 in 10. Most of the time I enter my details and press login and it works perfectly fine.

I've managed to get the login screen missing its styling 0 times. (Never.)


So two things.
#1. If anyone is having an issue and has NOT switched to the development build of Inner Space, start by doing that.

#2. I've built a test version of ISBoxer that forces the game to use "SSN" patching mode (download all files in advance) when launched by ISBoxer instead of "BR" (BitRaider, download on demand). ISBoxer originally used this behavior because BitRaider was not supported at all by Inner Space, but at some point SWTOR updated and broke SSN mode such that it kept going into a patching loop.

1. Grab this test version of ISBoxer Toolkit: https://www.lavishsoft.com/downloads/mods/ISBoxer.42.5.1219.1.zip
2. This zip file has in it just an ISBoxer Toolkit.exe file -- open it up and place the exe file in your Inner Space folder (typically C:\Program Files (x86)\InnerSpace), replacing your old ISBoxer Toolkit.exe.
3. Launch ISBoxer Toolkit
4. You should have a "Launcher.settings" Virtual File already assigned to your SWTOR characters.
5. Export to Inner Space. It SHOULD complain that the launcher is currently in BitRaider mode; click Yes to let ISBoxer change it
6. Try launching your team.

Again noting: SSN mode does a complete download of the client, and will probably do so when you launch your team the first time in this mode. The SSN/BR mode setting will not affect your SWTOR or launcher when not launched through ISBoxer.

Please let me know if this helps. I sent this test to someone already but have not yet received a response.
<<

lax

User avatar

Site Admin

Posts: 6912

Joined: Tue Nov 17, 2009 9:32 pm

Post Wed Dec 20, 2017 6:26 am

Re: SWTOR will not launch after new update

Also, if anyone would like real-time help instead of waiting for a forum post or e-mailed response, please come by the ISBoxer Discord. We have a chat channel created for SWTOR, just waiting for someone to drop in that wants to try to work this out together.
<<

lunacybooth

Posts: 2

Joined: Tue Dec 19, 2017 4:07 pm

Post Wed Dec 20, 2017 2:44 pm

Re: SWTOR will not launch after new update

I tried the dev build before posting, and no go, either it works 10 times out of 10 or fails 10 times out of 10 logging in.

I've downloaded the modified toolkit and will give that a go over the next couple of days, I'll let you know on discord how I get on.
<<

lax

User avatar

Site Admin

Posts: 6912

Joined: Tue Nov 17, 2009 9:32 pm

Post Thu Dec 21, 2017 10:57 am

Re: SWTOR will not launch after new update

I've reproduced the issue with the launcher not working. Stay tuned for an update. :)
<<

andyzipperer

Posts: 1

Joined: Mon Aug 04, 2014 7:21 pm

Post Tue Jan 16, 2018 7:08 pm

Re: SWTOR will not launch after new update

So is there a solution yet? I just bought more innerspace time, and I can't get it to load swtor. It shows a weird white version of the launcher but you can't log in.

I did just get it to open the regular launcher but it hangs and won't log in to the first inctance.
<<

Tekkno

Posts: 1

Joined: Sat Feb 24, 2018 6:40 am

Post Sat Feb 24, 2018 6:47 am

Re: SWTOR will not launch after new update

An update would be nice - even if just to say it's being worked on. I bought more time for IS in October/November, as it had worked so well before that - now I can't even log-in to the game without first having to run the launcher dozens of times (I wish I was exaggerating that figure). I very, very rarely get the 'no formatting' launcher - more often, I either get no launcher at all (although it does show in the task manager), or the spinning blue disc after putting in my login details. I then have to do this for each character - I've spent over an hour trying to log in two characters before...it gets frustrating enough that I do just give up.

I'm using the latest developer version, and I've reverted to the older patch version which was suggested - neither seem to be doing anything. I've also turned off anti-virus to see if that has any impact.

A new oddity which I've not seen mentioned - When I DO get it working, after closing the game, I then can't play anything from Steam. For some reason, they all launch at 1x1 pixel and can't be forced out of it. The only fix I've had for this is to restart my PC. I've no idea why this is, but it ONLY happens when I've played SWTOR through ISBoxer. Any idea on that?
<<

Lee Von

Posts: 11

Joined: Thu Aug 28, 2014 11:23 pm

Post Sun Feb 25, 2018 12:04 am

Re: SWTOR will not launch after new update

Just wanted to add that I too am experiencing this. I thought about getting back into SWTOR but with it taking so many tries to launch the game I don't think I will until this is resolved.
PreviousNext

Return to Star Wars: The Old Republic

Who is online

Users browsing this forum: No registered users and 2 guests