FAQ  •  Register  •  Login

Since patch, SWGemu won't launch.

Moderator: MiRai

<<

ANPres

Posts: 19

Joined: Sat Feb 07, 2015 9:02 pm

Post Wed Sep 27, 2017 8:51 pm

Since patch, SWGemu won't launch.

I've checked the config file, reloaded the .xlm file (or whatever) still won't launch.
Doesn't seem to be a problem with my other games.

This is a big deal for me as I require isboxer to play and SWG is my most beloved past times.
First time in the years that I've used isboxer I've had cause to cuss it.
(Prior to the patch I was getting error messages, every time I closed the game, which started a couple of weeks ago.)

Tell me how to fix this, please.

(I'll take a link to download an "unimproved" version, too.)

Thanks much.
<<

lax

User avatar

Site Admin

Posts: 6689

Joined: Tue Nov 17, 2009 9:32 pm

Post Wed Sep 27, 2017 9:22 pm

Re: Since patch, SWGemu won't launch.

https://www.lavishsoft.com/innerspace/archives
Follow instructions on the page to download version 6200, if that was the last one that worked for you

SWG is not in our current list of games we're testing against. I was planning to check on SWG soon to take care of the reported mouse issue, so stay tuned
<<

ANPres

Posts: 19

Joined: Sat Feb 07, 2015 9:02 pm

Post Wed Sep 27, 2017 9:29 pm

Re: Since patch, SWGemu won't launch.

I know it's not and I understand the decision behind this.. and at the same time, I've been able to continue to play SWG for years, despite not being supported.
It's just "this" patch is what's screwed me up.

I appreciate you quick response.
(And I do LOVE your software, couldn't game without it.)
<<

ANPres

Posts: 19

Joined: Sat Feb 07, 2015 9:02 pm

Post Wed Sep 27, 2017 9:45 pm

Re: Since patch, SWGemu won't launch.

As a follow up, 6200 will launch the game, so that's restored but I'm still getting the error message after closing.
I'm sending the error file per the progies request, so it's reporting the problem somewhere.

Thanks again.
<<

lax

User avatar

Site Admin

Posts: 6689

Joined: Tue Nov 17, 2009 9:32 pm

Post Fri Sep 29, 2017 1:51 pm

Re: Since patch, SWGemu won't launch.

Inner Space development build 6220 is now available and should solve the reported issues with SWGEmu. To try it out, right click Inner Space and select Patcher, tick "Download development (test) patches" and then close and restart Inner Space to let it patch up. Let me know :)
<<

ANPres

Posts: 19

Joined: Sat Feb 07, 2015 9:02 pm

Post Mon Oct 16, 2017 5:52 pm

Re: Since patch, SWGemu won't launch.

lax wrote:Inner Space development build 6220 is now available and should solve the reported issues with SWGEmu. To try it out, right click Inner Space and select Patcher, tick "Download development (test) patches" and then close and restart Inner Space to let it patch up. Let me know :)


Well....
After update I got like, 4 error messages, "Cannot load kernel.." blah, blah, blah. Basically looks like whatever was supposed to be updated, didn't.
I did also upgrade isbox suite.

But, Lax, I'm seeing just really weird stuff in the past few months.
Like, I'll run 18 screens, for some reason, one of them won't load, (even after trying to force it..) I close out, restart and it will come up.
One of my hotswaps to, say, screen 16, is alt-cntl-num2. Won't even take it. I had to move it to alt-contrl-numdel.
(And it's only worked for like, 3 years..) And "yes" the key is fine and works outside of *this* specific set up.

I don't get it. Here recently just all these little buggy bugs are popping up.
Now, despite the errors, it is launching and running.
(Still can't use my numlock 2 key tho. What's up with that??)

Thank you!
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 2664

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Mon Oct 16, 2017 8:18 pm

Re: Since patch, SWGemu won't launch.

ANPres wrote:After update I got like, 4 error messages, "Cannot load kernel.." blah, blah, blah. Basically looks like whatever was supposed to be updated, didn't.
When this occurs during Inner Space patching, it usually means you have a process which has the Inner Space DLL's loaded into it. If you have exited a game prior, then it has not shutdown correctly. You can chase it if you like, or you can do a computer reboot to clear it. Patch before trying to load anything else under Inner Space.

ANPres wrote:But, Lax, I'm seeing just really weird stuff in the past few months.
If you mean from prior to the 28th August, then ok, but that means defining aroundabout when it started, and was it after a game patch, Windows patch, or a specific InnerSpace patch? The archive doesn't have a full list so this might be hard to test, but if you could recall a specific timeframe that would probably help.
If you mean after 28th August, then that was when the rewrite of the Inner Space loader began (well it actually began earlier, but there were a couple of patches in the dev builds between the initial push of 6195 on 13th Sep), so that at least would be more specific, and help to indicate that the loader is not quite there yet with SWG.

ANPres wrote:One of my hotswaps to, say, screen 16, is alt-cntl-num2. Won't even take it. I had to move it to alt-contrl-numdel.
The NumPad is a funny beast (and I'm sure you know this stuff). Not the least because NumLock changes the 2 key between NUMPAD2 and DOWN (i.e. the ARROW), so it can depend on the numlock state as to whether CTRL+ALT+NUMPAD2 will do anything.
Question is, does it work if you use InnerSpace build 6174 (which was live from June to Sep), or just not at all?

ANPres wrote:Like, I'll run 18 screens, for some reason, one of them won't load, (even after trying to force it..) I close out, restart and it will come up.
With your games not loading, is this a new thing too? If so, then again, can you say when that started?, How about grabbing a compatibility diagnostic, as this would be the first place to start to look into this stuff, and see if there is anything obvious just lurking there.
One of the harder parts of this will always be that we wont be testing with 18 instances of the game, so if this is not reproducible with a lessor number, then we will be relying on you to provide some info. If it happens that the one that wont load actually hangs in the background, rather than a straight out refusal to load (which is probably a more fundamental issue), then it would probably help to get a Trace Diagnostic on the hung game.


ATEOTD, you can revert back to build 6174 if that was working for you. Currently the mouse issue for SWG has not been resolved at this time, so you wouldn't necessarily be missing out on anything by doing so.
<<

ANPres

Posts: 19

Joined: Sat Feb 07, 2015 9:02 pm

Post Tue Oct 17, 2017 12:34 am

Re: Since patch, SWGemu won't launch.

bob wrote:If you mean after 28th August, then that was when the rewrite of the Inner Space loader began (well it actually began earlier, but there were a couple of patches in the dev builds between the initial push of 6195 on 13th Sep), so that at least would be more specific, and help to indicate that the loader is not quite there yet with SWG.

ANPres wrote:One of my hotswaps to, say, screen 16, is alt-cntl-num2. Won't even take it. I had to move it to alt-contrl-numdel.
The NumPad is a funny beast (and I'm sure you know this stuff). Not the least because NumLock changes the 2 key between NUMPAD2 and DOWN (i.e. the ARROW), so it can depend on the numlock state as to whether CTRL+ALT+NUMPAD2 will do anything.
Question is, does it work if you use InnerSpace build 6174 (which was live from June to Sep), or just not at all?
.


Let me see if I can summarize a reponse.
Prior to 6200 (and maybe even one below?) Numlock worked and all screens loaded. Never had a single problem with anything on any of the games, for years. Lax had me downgrade back to 6200 and these issues stuck around. (Whichever one right above 6200, nothing would load.)

The thing about numlock, I'm using 1-6, they all worked prior to today's patch, except 2. Now, after patch, 1 and 4 doesn't work, 2 does. This is a proggie issue. I've gone back in and checked the programming and confirmed it's set right.

It "feels" like an interaction with a Windows update, (running 7) but I have no idea which one. I haven't kept track of the Windows updates, usually I only get 1 per month tho. IF memory serves, there was a recent .NET update, that might have been it? But y'all would know more about that than me.

Fortunately, I keep a restore point, prior to any Windoze updates, I might be able to do a rollback on that, I'll check tomorrow.
I'll also do a force shutdown and reinstall the ISboxer updates and see how that runs. I will say that I did that one before, still got the failed installs, so I went back down to the 6200.
(Sorry, I'm not keeping up with versions and I've got a rough idea on dates. I game every night, usually till 1 AM, so everything runs together.)
Like I said, I'll check my end and update tomorrow.
Thank you!!

[Edit: Sorry, the camera mode deal in SWG was never a big deal for me. I found a work around. The recent patch, what, 6200? Completely cleared it tho and it works like it did on LIVE.]
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 2664

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Tue Oct 17, 2017 5:46 am

Re: Since patch, SWGemu won't launch.

Before going through a restore point (because Inner Space install doesn't necessarily force one), you can grab build 6174 from the archive (https://www.lavishsoft.com/innerspace/archives). Instructions are on the page as to how to copy it over. If you can validate that the numpad and screen loading issues go away with that, then that would be helpful to know. It would also give you something stable to play on in the meantime (and it'll probably revert the mouselook too, but if it's not a big deal...)
<<

ANPres

Posts: 19

Joined: Sat Feb 07, 2015 9:02 pm

Post Tue Oct 17, 2017 7:02 pm

Re: Since patch, SWGemu won't launch.

bob wrote:Before going through a restore point (because Inner Space install doesn't necessarily force one), you can grab build 6174 from the archive (https://www.lavishsoft.com/innerspace/archives). Instructions are on the page as to how to copy it over. If you can validate that the numpad and screen loading issues go away with that, then that would be helpful to know. It would also give you something stable to play on in the meantime (and it'll probably revert the mouselook too, but if it's not a big deal...)


Ran patch, went fine.. 6223.
So far, so good. Numblock and screens all working as they should.

Now, mouselook is a little jittery, but I'll play with my settings and see if I can't create a workaround.

Thanks much!!

Return to Star Wars Galaxies

Who is online

Users browsing this forum: No registered users and 1 guest