Page 1 of 1

Logitech G910 support bug

PostPosted: Wed Apr 24, 2019 9:58 pm
by ThaSpike

Just recently bought a Logitech G910 after checking that it was supported on the Supported Input Devices page. The G-buttons work as expected but as soon as I start pressing the M-buttons all kind of weird things started to happen.

I made an empty profile with just a single menu to do some testing, see here. With this I noticed that somehow the M1-3 and MR button also activate the G1-3 buttons.

Could this please be fixed.

I use the M -buttons to switch between my different virtual menu's, worked as expected with my old Logitech G510s.


Re: Logitech G910 support bug

PostPosted: Wed Apr 24, 2019 10:29 pm
by bob
In order;

1. Check the logitech profile being assigned to the keyboard to ensure it is deliberately clear and not assigned any functions to the buttons
2. If using the logitech software in conjunction (at the same time) with the keyboard make sure it is loading as admin.
3. follow the instructions here
4. note the revision of the keyboard (diff revisions sometimes change things)

Re: Logitech G910 support bug

PostPosted: Wed Apr 24, 2019 11:04 pm
by ThaSpike
1. Yes it is.
2. Yes it is.
3. I'll check it out.
4. I will.

Thanks for the quick reply Bob

Re: Logitech G910 support bug

PostPosted: Wed Apr 24, 2019 11:34 pm
by ThaSpike
Send an email to

How long do you expect it will take before the changes are implemented?

Re: Logitech G910 support bug

PostPosted: Fri Jun 14, 2019 6:26 pm
by ThaSpike
Hey guys,

I know you're probably all very busy but I would be very grateful if you could try and fix the support for this keyboard.

Lax did respond to the initial email I send him and tried to fix it, unfortunately, the changes he implemented only partially solved the problem.

I've emailed him twice since, telling him what worked and what didn't. But I have not gotten any reaction from him since.

Could someone please have another look at this issue.

I've made an otherwise empty profile with a menu for all the G & M buttons on the Logitech G910, to test. The G-buttons all work fine. The M1-3 all only press the M1 button, but it stays in the pressed state after releasing the button. No reaction what so ever from the MR button.

The latter (MR button) I don't care about since I'm not using it.
I do want to use the M1-3 buttons to navigate the virtual menus I've setup.