FAQ  •  Register  •  Login

Weird keystroke / target group behavior

Moderator: MiRai



Posts: 70

Joined: Fri Jul 05, 2013 8:49 am

Post Sat Apr 07, 2018 8:21 pm

Weird keystroke / target group behavior

This one really has me scratching my head.

I'm playing LOTRO, but I don't think the game is the issue.

I've set up two action target groups: MOVEBACK and MOVEFORWARD. I set up a mapped key to send "S" to all members of MOVEBACK and "W" to all members of MOVEFORWARD. The mapped key is set hold any keystrokes while Hotkey is held. The idea is I want selected members of the group to move in opposite directions at the same time. The way things are set up, the same members can't be in both groups at once: you're either moving back, or your moving forward, or you're not moving.

When I press the hotkey, MOVEFORWARD works fine for everyone. No matter which slot is active, everyone in the MOVEFORWARD group consistently moves forward.

MOVEBACK works fine for everyone except the character in the current window. So, say character 1 and character 5 are in the MOVEBACK group. If I'm playing from slot 1/character 1, and I press the hotkey, I see character 5 move back but character 1 stays put. If I jump to character 5 and press the hotkey, I see character 1 move back but character 5 stays put. (Again, all the MOVEFORWARD characters move correctly, no matter who I'm on.)

I've opened up a debug console on all the screens. I can see the proper keystroke coming in, but it's like the game ignores it:
Button: from keystroke@is1: hold S
Button: from keystroke@is1: release S

So far I've tried using variable keystrokes instead of "hard" ones; I've swapped the key for backing up in game from S to another key and plumbed that one into the mapped key--doesn't matter. I've searched for any conflicts in my hotkeys. I've tried adding both the slot number and the character name to the groups. No joy.

The kicker is I see that keystroke coming in clear as day in debug. If a "W" comes in, he moves forward, but if an "S" or any other key mapped for going backwards comes in, he ignores it.

(Oh, and if I press an S directly on the keyboard it works fine.)

Thanks for any insight.


User avatar

League of Extraordinary Multiboxers

Posts: 3431

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sat Apr 07, 2018 8:57 pm

Re: Weird keystroke / target group behavior

I've just tested this out to see if I could replicate it. The only time it was a bit strange was if the option "make game believe it is foreground" was not selected on the character set, but that ended up with the opposite problem in that the slave didn't move (I only had two characters).

Problem appears to be local.


Posts: 70

Joined: Fri Jul 05, 2013 8:49 am

Post Sun Apr 08, 2018 8:30 am

Re: Weird keystroke / target group behavior

Agreed, something on my PC must somehow be interfering. But it gets a little weirder.

I tried sending "Q" instead of "S" to MOVEBACK. Everyone strafes left; it works fine. So then I remapped Q from "strafe left" to "move backward" in LOTRO. Everyone moves backward--that worked! I'm not about to live with Q as my move back key though.

I suppose if I really had to I could have isboxer take over the movement keys and virtualize them...have S for instance be a hot key for a key map that executes a virtual keystroke that presses Q and remap Q for everyone in game, ditto for Q to S. (Yeah this is making me more batshit than usual.)

It's one of those times I think the answer is right there, just can't see it.

Return to Key Maps

Who is online

Users browsing this forum: No registered users and 4 guests