FAQ  •  Register  •  Login

[EVE] ALT GR problem

Moderator: MiRai

<<

Losalas

Posts: 2

Joined: Thu May 10, 2012 11:58 am

Post Thu May 10, 2012 12:09 pm

ALT GR problem

Hello

I'm new to use Isboxer , but I have an issue with the default switcher ctrl+alt+1-2-3-4 etc.
It seems when I try to type e.g. my email while in game it having a hard time typing in @ because I use alt gr+2.
Instead it just switch focus to an other game window

here is the question is it possible to disable the default focus switcher?


P.S. sorry for my poor English
<<

Kaische

Posts: 164

Joined: Sat Jan 08, 2011 12:11 am

Location: Germany

Post Thu May 10, 2012 1:03 pm

Re: ALT GR problem

Yes, you can change those Per-window Hotkeys
<<

Losalas

Posts: 2

Joined: Thu May 10, 2012 11:58 am

Post Thu May 10, 2012 1:21 pm

Re: ALT GR problem

Thanks :D now its working without problem ;)
<<

Macklol

Posts: 6

Joined: Sat May 12, 2012 12:01 pm

Post Sat May 12, 2012 12:04 pm

Re: ALT GR problem

I have the same problem, this didn't solve it. I bound each window to CTRL+F1 through F5. Cannot type @ so I have to paste my email address when logging into a game. The game is WoW but I guess it doesn't really matter.

http://www.privatepaste.com/49c1fa11ed
<<

lax

User avatar

Site Admin

Posts: 6884

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat May 12, 2012 12:25 pm

Re: ALT GR problem

I have the same problem, this didn't solve it. I bound each window to CTRL+F1 through F5. Cannot type @ so I have to paste my email address when logging into a game. The game is WoW but I guess it doesn't really matter.

It's actually supposed to detect that you have an Alt Gr key, and not use the Ctrl+Alt+# hotkeys at all. So I'll have to look into that again. After you changed the Hotkeys, did you Export to Inner Space? Because there's no reason it should switch windows anymore with Ctrl+Alt+2 if you have assigned Slot 2 to Ctrl+F2...
<<

Macklol

Posts: 6

Joined: Sat May 12, 2012 12:01 pm

Post Sat May 12, 2012 12:29 pm

Re: ALT GR problem

lax wrote:
I have the same problem, this didn't solve it. I bound each window to CTRL+F1 through F5. Cannot type @ so I have to paste my email address when logging into a game. The game is WoW but I guess it doesn't really matter.

It's actually supposed to detect that you have an Alt Gr key, and not use the Ctrl+Alt+# hotkeys at all. So I'll have to look into that again. After you changed the Hotkeys, did you Export to Inner Space? Because there's no reason it should switch windows anymore with Ctrl+Alt+2 if you have assigned Slot 2 to Ctrl+F2...


I exported using File > Export All to Inner Space. Do I have to restart ISBoxer or something?

edit: I actually have another problem, some of my keybinds are "delayed". If I type a word, say "numb3rs" and type that inside wow it will be "numbr3s" or "numbrs3". It is delayed no matter how many WoW instances I have loaded WITH ISBoxer, not when I load the game by itself.
Last edited by Macklol on Sat May 12, 2012 1:17 pm, edited 2 times in total.
<<

lax

User avatar

Site Admin

Posts: 6884

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat May 12, 2012 1:17 pm

Re: ALT GR problem

I exported using File > Export All to Inner Space. Do I have to restart ISBoxer or something?

No; worst case, re-launch your team after Exporting.

Edit: I actually have another problem, some of my keybinds are "delayed". If I type a word, say "numb3rs" and type that inside wow it will be "numbr3s" or "numbrs3". It is delayed no matter how many WoW instances I have loaded WITH ISBoxer, not when I load the game by itself.

As a general rule, when you're intend to use ISBoxer's Hotkeys for purposes other than what they are mapped to do (e.g. use the 3 button for typing in a chat box instead of auto-assist+broadcast), it is a good idea to temporarily disable them with Shift+Alt+M.

For this in particular, you're expecting 3 to fire on Press as you type, but it fires on Release on default. In the top left pane in ISBoxer, under Key Maps, select "FTL DPS Keys". Then in the bottom right pane, adjust "Execute a Step when the Hotkey is _______" to be "pressed" instead of "released, then Export. However, if you don't temporarily turn off Key Maps you're still going to be instructing the other windows to assist and broadcast the 3 button as you type it.
<<

Macklol

Posts: 6

Joined: Sat May 12, 2012 12:01 pm

Post Sat May 12, 2012 1:20 pm

Re: ALT GR problem

Okay, that makes sense with the delay, didn't think of that. Did you find the problem with the ALT GR issue? I have tried re-launching WoW/team couple of times, restarted ISBoxer and re-exporting.
<<

lax

User avatar

Site Admin

Posts: 6884

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat May 12, 2012 1:27 pm

Re: ALT GR problem

If you have multiple Inner Space folders for some reason, you might be Exporting to the wrong one, and no changes would take effect.... in the top left pane in ISBoxer, at the very top, select "ISBoxer"... then in the bottom right pane, make sure the "Inner Space folder" path is pointing to the right place.

You seem to be wanting a lot of real-time support, why don't you just come to the ISBoxer Chat Room ;)
<<

lax

User avatar

Site Admin

Posts: 6884

Joined: Tue Nov 17, 2009 9:32 pm

Post Sat May 12, 2012 2:44 pm

Re: ALT GR problem

Update: Macklol came to the chat room and it did turn out to be a bug with Alt Gr on Swedish keyboard layouts (and possibly others) that needed to be fixed. Inner Space build 5612 fixes this issue. This is currently the development build of Inner Space. To try it out, right click IS and select Patcher, check "Download development (test) patches" then close and restart Inner Space to let it patch up.
Next

Return to Key Maps

Who is online

Users browsing this forum: No registered users and 2 guests

cron