FAQ  •  Register  •  Login

Virtual Mapped Keys not editable

Moderator: MiRai

<<

eternaldrk

Posts: 5

Joined: Sun Jul 16, 2017 4:54 pm

Post Sun Jul 16, 2017 5:24 pm

Virtual Mapped Keys not editable

So I've never run into this issue and I've been using ISBoxer for years. This is a completely fresh install of everything as this PC was rebuilt a few weeks ago. I am completely unable to change any Virtual Mapped Key for either my sole character set, or the individual characters. My only issue previously was how poorly the UI renders in 4K making it nearly impossible to click the button. In this case though, the drop downs are missing entirely. No response from keyboard shortcuts either. Can't really box without the Interact with Target option being set.


I've pasted a screenshot and pastebin of my profile below:

Profile:
https://pastebin.com/bH8VyMKv
Screencap:
http://imgur.com/oD2yNCb

My System:
Windows 10 64-Bit
Ryzen 1700X
32GB RAM
NVidia GTX 1070


Things I've tried so far:
Keyboard shortcuts
Restarting PC
Reinstalling ISBoxer suite
Re-creating character set
Changing screen resolution
Running ISBoxer in compatibilty mode (Windows 8, 7, XP Service Pack 3)
Running ISBoxer in Administrative mode
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3521

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sun Jul 16, 2017 7:24 pm

Re: Virtual Mapped Keys not editable

You seem to be missing some controls altogether.

Normally the issue with 4K, is you are using Display Scaling, which the toolkit just isn't designed to deal with.
You could try try setting an Application Compatibility setting for this (we normally recommend against them, but these one have a specific scenario).

The setting is either (depending on version of Windows 10),
"Disable display scaling on high DPI settings" or
"Override high DPI scaling behaviour. Scaling performed by:" and select Application in the drop down.

This would be set for the C:\Program Files (x86)\InnerSpace\ISBoxer Toolkit.exe

The settings above basically tell Windows that the program has NFC about display scaling and not to apply it.

Other than that, the other option is to use scaling of 100%.
<<

eternaldrk

Posts: 5

Joined: Sun Jul 16, 2017 4:54 pm

Post Sun Jul 16, 2017 8:04 pm

Re: Virtual Mapped Keys not editable

That did the trick, thanks! Enabling Override high DPI scaling behavior and setting the scaling to be performed by System (Enhanced) not only brought all of the controls back, but made some of the other fonts much easier to read.

Thanks again!
<<

eternaldrk

Posts: 5

Joined: Sun Jul 16, 2017 4:54 pm

Post Sat Feb 09, 2019 8:46 pm

Re: Virtual Mapped Keys not editable

Just jumping back into multi-boxing on a new setup and discovered something related to using the Override High DPI scaling behavior to restore controls in ISBoxer. When this setting is enabled with System (Enhanced) at 4K resolution in Windows 10, the Window Layout Wizard will no longer work correctly. Window dimensions will be completely off. I didn't know what was causing this previously, and had to calculate window dimensions myself and never quite reaching the right size or aspect ratio. So, to summarize:

@4K Resolution: Override High DPI --> System (Enhanced) == really bad Window Layout Wizard results.
<<

Wizeowel

Posts: 23

Joined: Mon Dec 10, 2018 11:13 am

Post Sat Feb 16, 2019 8:27 am

Re: Virtual Mapped Keys not editable

eternaldrk wrote:Just jumping back into multi-boxing on a new setup and discovered something related to using the Override High DPI scaling behavior to restore controls in ISBoxer. When this setting is enabled with System (Enhanced) at 4K resolution in Windows 10, the Window Layout Wizard will no longer work correctly. Window dimensions will be completely off. I didn't know what was causing this previously, and had to calculate window dimensions myself and never quite reaching the right size or aspect ratio. So, to summarize:

@4K Resolution: Override High DPI --> System (Enhanced) == really bad Window Layout Wizard results.


I am also using System (Enhanced) and the Layout Wizard works fine for me - Program DPI is switched off however.

Nah, hang on, I see what you mean now. It made everything 2560x1440. I guess because the scaling is 150% so 3840/1.5=2560.

Okay so the solution is: when starting the Window Layout Wizard, click the '...' next to Use Monitors. Change the Bounds to 3840,2160 and the Working Area to 3840,2100

Return to Key Maps

Who is online

Users browsing this forum: No registered users and 4 guests