FAQ  •  Register  •  Login

DAoC Quickbars not working

Moderator: MiRai

<<

Grimduke

Posts: 6

Joined: Fri Apr 13, 2018 5:57 am

Post Sun Apr 15, 2018 3:57 am

DAoC Quickbars not working

Hi guys,

Can someone confirm that broadcasting abilities on the second and third quickbar in Dark age of Camelot is nigh impossible, essentially limiting your broadcasting to only 1 quickbar.

Secondary quickbar has ALT as a modifier. Example: ALT+1, ALT+2
Third quickbar has CTRL as a modifier. Example: CTRL+1, CTRL+2

None of the above commands will broadcast correctly.

Can we resolve this somehow? I feel like this constraint is having a large impact on the multiboxing functionality for DAoC.
<<

bob

User avatar

League of Extraordinary Multiboxers

Posts: 3191

Joined: Sat Feb 15, 2014 11:14 am

Location: In the dining room, with the lead pipe.

Post Sun Apr 15, 2018 5:32 am

Re: DAoC Quickbars not working

A quick test would be to enable broadcasting, disable key maps, and press the ALT+NUM or CTRL+NUM and see if all the toons attempt to use their abilities on their quick bars. If they do, then the issue is going to be that something else is missing somewhere in the config.

Are you pressing hotkeys to attempt to trigger your quick bars? If so, then under IBS42 - Combat Broadcast Hotkeys, do the ALT+NUM and CTRL+NUM mapped keys have hotkeys set (you can quickly tell by the light grey text to the right of the mapped key)?.
<<

Grimduke

Posts: 6

Joined: Fri Apr 13, 2018 5:57 am

Post Sun Apr 15, 2018 10:06 am

Re: DAoC Quickbars not working

bob wrote:A quick test would be to enable broadcasting, disable key maps, and press the ALT+NUM or CTRL+NUM and see if all the toons attempt to use their abilities on their quick bars. If they do, then the issue is going to be that something else is missing somewhere in the config.

Are you pressing hotkeys to attempt to trigger your quick bars? If so, then under IBS42 - Combat Broadcast Hotkeys, do the ALT+NUM and CTRL+NUM mapped keys have hotkeys set (you can quickly tell by the light grey text to the right of the mapped key)?.


In the attached screenshot is my ISB42 - Combat Broadcast Hotkeys, which is showing the grey indication I think you are referring to. I will try your testing methodology and return with results. I am very keen on finding a work around to this issue.'

combatbroadcasts.png
combatbroadcasts.png (7.27 KiB) Viewed 978 times


P.s I'm having a terrible time trying to post anything on this forum without receiving: The submitted form was invalid. Try submitting again.
<<

Grimduke

Posts: 6

Joined: Fri Apr 13, 2018 5:57 am

Post Sun Apr 15, 2018 10:35 am

Re: DAoC Quickbars not working

bob wrote:A quick test would be to enable broadcasting, disable key maps, and press the ALT+NUM or CTRL+NUM and see if all the toons attempt to use their abilities on their quick bars. If they do, then the issue is going to be that something else is missing somewhere in the config.

Are you pressing hotkeys to attempt to trigger your quick bars? If so, then under IBS42 - Combat Broadcast Hotkeys, do the ALT+NUM and CTRL+NUM mapped keys have hotkeys set (you can quickly tell by the light grey text to the right of the mapped key)?.


Ok I have done your test.

Broadcasts ON + Keymaps OFF = ALT+1 Will activate abilities on all characters.
Broadcasts OFF + Keymaps ON = ALT+1 Will activate just one ability in the active window.

How can we remedy this?
<<

MiRai

User avatar

Vibrant Videographer

Posts: 2660

Joined: Fri Nov 20, 2009 3:30 pm

Post Sun Apr 15, 2018 11:04 am

Re: DAoC Quickbars not working

Grimduke wrote:How can we remedy this?

For DAoC, I believe you should go into the Mapped Keys in "Combat Broadcast" (where there are no Hotkeys assigned), and enable the "Hold any Keystroke..." setting for all Mapped Keys with a modifier key. This will remove the ability to auto-assist, but I don't believe it's used for DAoC anyway.
<<

Grimduke

Posts: 6

Joined: Fri Apr 13, 2018 5:57 am

Post Sun Apr 15, 2018 3:07 pm

Re: DAoC Quickbars not working

MiRai wrote:
Grimduke wrote:How can we remedy this?

For DAoC, I believe you should go into the Mapped Keys in "Combat Broadcast" (where there are no Hotkeys assigned), and enable the "Hold any Keystroke..." setting for all Mapped Keys with a modifier key. This will remove the ability to auto-assist, but I don't believe it's used for DAoC anyway.


You're right about the auto assist, that functionality should be turned off for the quick setup wizard when DAoC is selected. Otherwise the other slots will change target as you broadcast them to attack a target.

Here is a screenshot of the Alt+1 Combat Broadcast hotkey:
holdkey.png
holdkey.png (21.78 KiB) Viewed 954 times


Even with these settings It will not function properly.
<<

MiRai

User avatar

Vibrant Videographer

Posts: 2660

Joined: Fri Nov 20, 2009 3:30 pm

Post Sun Apr 15, 2018 4:02 pm

Re: DAoC Quickbars not working

Grimduke wrote:Here is a screenshot of the Alt+1 Combat Broadcast hotkey:
[Image]
Even with these settings It will not function properly.

Right, there are two Key Maps in question:

Combat Broadcast Hotkeys - Where your Hotkeys should be set (The Hold option is already enabled in this Key Map)
Combat Broadcast - The Key Map that is linked to Combat Broadcast Hotkeys

Your image is showing what's already configured by the Wizard in "Combat Broadcast Hotkeys," but the changes I am suggesting be made to the Hold option will need to be done in "Combat Broadcast" (without the word "Hotkeys").
<<

Grimduke

Posts: 6

Joined: Fri Apr 13, 2018 5:57 am

Post Mon Apr 16, 2018 4:56 am

Re: DAoC Quickbars not working

MiRai wrote:
Grimduke wrote:Here is a screenshot of the Alt+1 Combat Broadcast hotkey:
[Image]
Even with these settings It will not function properly.

Right, there are two Key Maps in question:

Combat Broadcast Hotkeys - Where your Hotkeys should be set (The Hold option is already enabled in this Key Map)
Combat Broadcast - The Key Map that is linked to Combat Broadcast Hotkeys

Your image is showing what's already configured by the Wizard in "Combat Broadcast Hotkeys," but the changes I am suggesting be made to the Hold option will need to be done in "Combat Broadcast" (without the word "Hotkeys").


Will test and confirm this afternoon. Thank you so far! :)
<<

Grimduke

Posts: 6

Joined: Fri Apr 13, 2018 5:57 am

Post Mon Apr 16, 2018 2:27 pm

Re: DAoC Quickbars not working

It worked like a charm MiRai, thanks for the assistance.

I am attempting to have my combat broadcasting of 1-9 add the assist command infront so I don't have to ALT+A. How would you do that? I tried just adding extra actions like this:
autoassist.png
autoassist.png (239.13 KiB) Viewed 912 times


My Character set virtual mapped keys:
characterset.png
characterset.png (24.39 KiB) Viewed 912 times


My variable hotkey for assist, which is confirmed working:
assist.png
assist.png (62.91 KiB) Viewed 912 times


Can you help me shed some light on why my attempt did not work? My characters will target my target, but they do not fire abilities, they cycle to target my main character before targeting my target again.
<<

MiRai

User avatar

Vibrant Videographer

Posts: 2660

Joined: Fri Nov 20, 2009 3:30 pm

Post Mon Apr 16, 2018 6:30 pm

Re: DAoC Quickbars not working

Grimduke wrote:Can you help me shed some light on why my attempt did not work? My characters will target my target, but they do not fire abilities, they cycle to target my main character before targeting my target again.

It doesn't work because:

1) The Hold option is now enabled (as I had mentioned in my first reply in this thread), and this "merges" every Action to be sent together as if they key is being held down.
2) Target {SLOT} requires a two-step Mapped Key: One for the F-key to be sent, and a second for the Assist or Follow command to be sent.

The only way you could integrate an assist into your keys when using the Target {SLOT} method would be to build a completely custom set of multi-step Mapped Keys that would include the F-key target, the assist being sent, and then the final keystroke for the hotbar. These MKs would likely have to be three steps—requiring three presses of the key—as you could not change the MK execution to "pressed or released" with the Hold option enabled.

The simplest solution, would be to change your assist key to something that is more accessible than ALT+A.

Return to Other

Who is online

Users browsing this forum: No registered users and 6 guests